Package Details: qtcreator-gitqlient-plugin-git r37.df1b2a7-1

Git Clone URL: https://aur.archlinux.org/qtcreator-gitqlient-plugin-git.git (read-only, click to copy)
Package Base: qtcreator-gitqlient-plugin-git
Description: GitQlientPlugin provides you a plugin to integrate Git in QtCreator full UI oriented
Upstream URL: https://github.com/francescmm/GitQlientPlugin
Licenses: MIT
Conflicts: qtcreator-gitqlient-plugin
Provides: qtcreator-gitqlient-plugin
Submitter: aa13q
Maintainer: aa13q
Last Packager: aa13q
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-24 22:24 (UTC)
Last Updated: 2020-02-24 22:24 (UTC)

Latest Comments

nyanpasu64 commented on 2021-07-22 08:19 (UTC)

It fails to build on my machine:

g++ -Wl,-z,origin '-Wl,-rpath,$ORIGIN:$ORIGIN/build/usr/lib/qtcreator:$ORIGIN/build/usr/lib/qtcreator/plugins' -Wl,--no-undefined -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-rpath-link,/usr/lib -shared -Wl,-soname,libGitQlientPlugin.so -o libGitQlientPlugin.so .obj/release-shared/GitQlientPlugin.o... -L/usr/lib/qtcreator -L/usr/lib/qtcreator/plugins -Lbuild/usr/lib/qtcreator -Lbuild/usr/lib/qtcreator/plugins -lCore -lProjectExplorer -lTextEditor -lQtcSsh -lAggregation -lExtensionSystem -lUtils -lKSyntaxHighlighting /usr/lib/libQt5WebEngineWidgets.so /usr/lib/libQt5WebEngineCore.so /usr/lib/libQt5Quick.so /usr/lib/libQt5PrintSupport.so /usr/lib/libQt5Widgets.so /usr/lib/libQt5Gui.so /usr/lib/libQt5QmlModels.so /usr/lib/libQt5WebChannel.so /usr/lib/libQt5Qml.so /usr/lib/libQt5Network.so /usr/lib/libQt5Positioning.so /usr/lib/libQt5Concurrent.so /usr/lib/libQt5Core.so -lGL -lpthread    
/usr/bin/ld: cannot find -lQtcSsh
/usr/bin/ld: cannot find -lAggregation
/usr/bin/ld: cannot find -lExtensionSystem
/usr/bin/ld: cannot find -lUtils
/usr/bin/ld: cannot find -lKSyntaxHighlighting
collect2: error: ld returned 1 exit status
make: *** [Makefile:1156: build/usr/lib/qtcreator/plugins/libGitQlientPlugin.so] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
error: failed to build 'qtcreator-gitqlient-plugin-git-r37.df1b2a7-1': 
error: packages failed to buid: qtcreator-gitqlient-plugin-git-r37.df1b2a7-1