Package Details: qtcreator-prerelease 13.0.0beta2-1

Git Clone URL: https://aur.archlinux.org/qtcreator-prerelease.git (read-only, click to copy)
Package Base: qtcreator-prerelease
Description: Qt Creator prerelease/latest
Upstream URL: http://qt.io/ide
Licenses: GPL
Conflicts: litehtml, qtcreator
Provides: qtcreator
Submitter: sirspudd
Maintainer: sirspudd (jakepetroules)
Last Packager: sirspudd
Votes: 4
Popularity: 0.31
First Submitted: 2016-03-25 23:15 (UTC)
Last Updated: 2024-03-01 00:16 (UTC)

Dependencies (19)

Required by (34)

Sources (1)

Latest Comments

1 2 Next › Last »

mergen commented on 2024-02-18 09:08 (UTC)

@sisrpudd Much appreciated

sirspudd commented on 2024-02-17 19:38 (UTC)

@mergen: Yep, sorry, I was a complete idiot and mangled the build dependencies. I moved off clang since the packaged one is archaic in Arch, but am still explicitly using mold which was not being provisioned before. My bad. Fixed.

mergen commented on 2024-02-17 09:16 (UTC)

I get a few warning and a fatal error when I compile this package: https://hastebin.skyra.pw/urayugatek.swift

Is there a solution for this?

sirspudd commented on 2020-05-10 00:05 (UTC)

Fixed

sirspudd commented on 2020-04-30 20:57 (UTC)

This package is currently looking green around the gills; will debug it when I get a chance

sirspudd commented on 2020-04-30 19:58 (UTC)

Thanks for the heads up, addressed

arojas commented on 2020-04-30 18:31 (UTC)

Needs the same patch as the stable version for clang 10

MikeD commented on 2020-04-30 18:21 (UTC) (edited on 2020-04-30 18:22 (UTC) by MikeD)

Hello, I'm getting linker errors:

clang++ -ccc-gcc-name g++ -Wl,-z,origin '-Wl,-rpath,$ORIGIN:$ORIGIN/../:$ORIGIN/.' -Wl,--exclude-libs,ALL -shared -Wl,-soname,libClangFormat.so -o libClangFormat.so .obj/release-shared/clangformatbaseindenter.o .obj/release-shared/clangformatconfigwidget.o .obj/release-shared/clangformatindenter.o .obj/release-shared/clangformatplugin.o .obj/release-shared/clangformatsettings.o .obj/release-shared/clangformatutils.o .obj/release-shared/moc_clangformatconfigwidget.o .obj/release-shared/moc_clangformatplugin.o  -L/home/mike/.cache/yay/qtcreator-prerelease/src/qt-creator-opensource-src-4.12.0-rc1/lib/qtcreator -L/home/mike/.cache/yay/qtcreator-prerelease/src/qt-creator-opensource-src-4.12.0-rc1/lib/qtcreator/plugins -lCppTools -lProjectExplorer -lCppEditor -lCore -lTextEditor -lQtcSsh -lCPlusPlus -lAggregation -lExtensionSystem -lUtils -lKSyntaxHighlighting -L/usr/lib -lclangFormat -lclangToolingInclusions -lclangToolingCore -lclangRewrite -lclangLex -lclangBasic -lLLVM-10 /usr/lib/libQt5Widgets.so /usr/lib/libQt5Gui.so /usr/lib/libQt5Concurrent.so /usr/lib/libQt5Network.so /usr/lib/libQt5Core.so -lGL -lpthread

/usr/bin/ld: cannot find -lclangFormat
/usr/bin/ld: cannot find -lclangToolingInclusions
/usr/bin/ld: cannot find -lclangToolingCore
/usr/bin/ld: cannot find -lclangRewrite
/usr/bin/ld: cannot find -lclangLex
/usr/bin/ld: cannot find -lclangBasic

arojas commented on 2019-07-13 07:35 (UTC)

@sirspudd regardless of this being qtcreator-prerelease, the version number is wrong. The version number must specify exactly what is being installed. You didn't even bump the pkgrel in the last update so users won't get notified there's a newer version.

The usual solution for the hyphen problem is to either replace it with an allowed character or remove it and call it 4.10.0beta2

sirspudd commented on 2019-07-11 18:33 (UTC)

@arojas:

https://wiki.archlinux.org/index.php/PKGBUILD#Version

"It can contain letters, numbers, periods and underscores, but not a hyphen (-)."

because 4.10.0-beta2 is an invalid version number; you are aware this is qtcreator-prerelease and not qtcreator, right?