Package Details: qtermwidget-git 1.0.0.14.g76b4e9f-1

Git Clone URL: https://aur.archlinux.org/qtermwidget-git.git (read-only, click to copy)
Package Base: qtermwidget-git
Description: A terminal widget for Qt, used by QTerminal
Upstream URL: https://github.com/lxqt/qtermwidget
Licenses: custom:public domain, LGPL, custom:BSD
Conflicts: qtermwidget
Provides: qtermwidget
Submitter: vicky91
Maintainer: yan12125
Last Packager: yan12125
Votes: 40
Popularity: 0.000010
First Submitted: 2011-12-15 22:27 (UTC)
Last Updated: 2022-03-12 04:07 (UTC)

Required by (16)

Sources (1)

Latest Comments

yan12125 commented on 2021-12-24 12:22 (UTC) (edited on 2022-03-12 04:11 (UTC) by yan12125)

Update: PyQt bindings are fixed.

Due to an upstream issue [1], PyQt bindings no longer build. If you need them, a short term workaround is keeping the old qtermwidget-git package or switching to the stable version of qtermwidget in [community]. In the long term, I will try to fix PyQt bindings before the next LXQt release.

[1] https://github.com/lxqt/qtermwidget/pull/460

yan12125 commented on 2021-09-21 03:00 (UTC)

Thanks! I thought I fixed the SIP issue, but it turns out I only fixed it locally.

qumaciel commented on 2021-09-19 13:15 (UTC)

qtermwidget-git depends on sip that has received a major update, apparently breaking it into several smaller tools. The package in the [extra] repository provides the new version, thus build fails.

To fix that manually install sip4. It'll provide the needed /usr/bin/sip for successful installation.

yan12125 commented on 2018-07-11 11:58 (UTC)

Most likely you have an old lxqt-build-tools-git. Try rebuild it first.

Tharbad commented on 2018-07-11 06:15 (UTC) (edited on 2018-07-11 06:15 (UTC) by Tharbad)

got:

CMake Error at CMakeLists.txt:37 (find_package): Could not find a configuration file for package "lxqt-build-tools" that is compatible with requested version "0.5.0".

The following configuration files were considered but not accepted:

/usr/share/cmake/lxqt-build-tools/lxqt-build-tools-config.cmake, version: 0.4.0

-- Configuring incomplete, errors occurred!

yan12125 commented on 2017-07-12 13:37 (UTC)

Hello, lxqt-build-tools is now a makedepends since https://github.com/lxde/qtermwidget/pull/116. Could you update it?

pmattern commented on 2015-12-22 19:22 (UTC)

Upstream URL and source should point to github.com/lxde/qtermwidget by now.

florianbw commented on 2015-05-09 03:11 (UTC)

Fails to build, solution by krabat works

pmattern commented on 2015-01-22 21:50 (UTC)

Package fails to install as it's treating /usr/lib64 as directory. Same problem and hence solution (-DCMAKE_INSTALL_LIBDIR=lib) as seen with e. g. liblxqt-git recently. Wouldn't it make sense to state qterminal-git as "Required by" on this page, as well?

trollixx commented on 2014-10-03 17:06 (UTC)

Probably description should be updated since it is a Qt 5 library now.

Funkin-Stoopid commented on 2013-08-24 21:28 (UTC)

@stozi change line echo "$(git shortlog | grep -c '\s\+').$(git describe --always)" by echo "$(git shortlog | grep -c '\s\+').$(git describe --always) | cut -d '-' -f 1"

stozi commented on 2013-08-07 12:17 (UTC)

ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.

adaptee commented on 2013-03-02 14:40 (UTC)

It tries to use Qt5 when both Qt4 and Qt5 are available and fails. Please add "-DQT_QMAKE_EXECUTABLE=qmake-qt4" to enforce using Qt4.

kreed commented on 2012-12-23 16:24 (UTC)

The PKGBUILD should correctly install to /usr/lib now.

commented on 2012-11-12 20:33 (UTC)

Is it possible to fix package build for this package once for all. IMHO it is good when package installation just works without some additive workarounds that i am lazy to perform :o)

alium commented on 2012-08-02 09:16 (UTC)

For those of you who would like to use this package edit the package build as follows; package() { cd "$srcdir/$_gitname-build" make DESTDIR="$pkgdir/" install mv $pkgdir/usr/lib64 $pkgdir/usr/lib }

commented on 2012-04-30 03:45 (UTC)

cmake should be added as makedepends.