Package Details: qtpad-git r197.4bf9b49-1

Git Clone URL: https://aur.archlinux.org/qtpad-git.git (read-only)
Package Base: qtpad-git
Description: Modern and customizable sticky note application
Upstream URL: https://gitlab.com/william.belanger/qtpad
Licenses: GPL3
Conflicts: qtpad
Provides: qtpad
Submitter: alfalfa
Maintainer: alfalfa
Last Packager: alfalfa
Votes: 4
Popularity: 0.018167
First Submitted: 2018-01-31 21:19
Last Updated: 2019-01-02 14:12

Latest Comments

prosoitos commented on 2018-08-08 08:59

@alfalfa thank you very much for that reddit link. Super useful.

I don't have yaourt, but I always install packages manually. I normally git pull any update, then install with makepkg -sirc. But this was not working. Deleting the package folder, redownloading it and then reinstalling it did however work. So I learnt something about python updates and also about how to reinstall a package that is broken (cd to that package and makepkg -sirc may not be enough. And deleting and redownloading might do the trick).

Thanks to your link, I found additional packages that needed to be rebuild (one not from the AUR actually).

Of note, the packages with segfault at start had a totally different problem, with glibc 2.28 (see https://bugs.archlinux.org/task/59550). They got patched by the maintainers by adding glibc-2.27 within the packages...

alfalfa commented on 2018-08-07 09:46

@prosoitos the bug seems to be related to the Python 3.7 upgrade, as some packages need to migrate from /usr/lib/python3.6/site-packages to python3.7/site-packages folder. See https://www.reddit.com/r/archlinux/comments/950v0b/aurman_raises_distributionnotfound_error/

Meanwhile I suggest you try to install the broken packages manually. Supposing that you have yaourt installed:

yaourt -R qtpad-git
sudo pacman -Syu
git clone https://aur.archlinux.org/qtpad-git.git
cd qtpad-git
makepkg -sri

prosoitos commented on 2018-08-07 08:24

Actually, I just had a look at the other 2 packages and it is reported there as well that they broke with the last updates.

prosoitos commented on 2018-08-07 02:54

@alfalfa thank you for your reply.

After my latest updates, I have been getting this message for qtpad and one other package, for which the bug was also reported. Maybe it isn't python 3.7.0-3, but another package which just got updated?

An additional 2 packages are not launching anymore, but no error message is sent. All 4 packages are from the AUR and it all started after the last updates (today, with lots of packages, including python). The fact that for at least one of those packages, someone also reported that it broke with latest updates makes me believe that it may not just be my system. No?

I am definitely running the latest qtpad package. Reinstalling it had no effect.

alfalfa commented on 2018-08-07 00:57

@prosoitos I updated python to 3.7.0-3 but could not reproduce the bug, neither with AUR or pip. The error message you've shown is a little strange since setup.py version was incremented to 0.0.8 a week ago. Maybe you are trying to install an old package from your cache?

prosoitos commented on 2018-08-07 00:01

Broke with latest python updates.

pkg_resources.DistributionNotFound: The 'qtpad==0.0.7' distribution was not found and is required by the application

alfalfa commented on 2018-02-01 20:01

@fabertawe That seems to be the expected behavior for vcs packages (-git). I guess it is tolerable since the program is very light. However I understand that it is not ideal and there might be more proper releases in the future. see https://bbs.archlinux.org/viewtopic.php?id=233810#14

fabertawe commented on 2018-02-01 13:51

Hi, package version is '0.0.0-1' but changed in PKGBUILD pkgver() to 'r101.a210678-1'. Then when I check for an update (using Cower) I get 'qtpad-git r101.a210678-1 -> 0.0.0-1' (stuck in update loop).