Package Details: quartus-standard 17.1.1.593-1

Git Clone URL: https://aur.archlinux.org/quartus-standard.git (read-only)
Package Base: quartus-standard
Description: Quartus Prime Standard Edition design software for Altera FPGA's. Modular package
Upstream URL: http://dl.altera.com/?edition=standard
Licenses: custom
Submitter: riaqn
Maintainer: None
Last Packager: Sequencer
Votes: 0
Popularity: 0.000000
First Submitted: 2017-02-16 02:47
Last Updated: 2018-02-24 04:11

Pinned Comments

riaqn commented on 2017-02-16 09:16

TODO:

1. replace manual intervention with exepct script.
2. if you see "Inconsistency detected by ld.so: dl-close.c: 759: _dl_close: Assertion `map->l_init_called\' failed!", this problem has been discussed on internet, and the solution is to delete several shipped 3rd-party libraries like curl. In the future we will delete these .so files in the package and add these libraries as dependencies.

Latest Comments

Sequencer commented on 2018-10-31 06:12

sorry I no longer use altera anymore.

balciu commented on 2018-07-28 15:19

Hey @Sequencer, are you going to update the package to 18.0?

gasparka commented on 2018-03-20 13:21

Installation hangs with 100% CPU usage (have been waiting for ~1h). Console prints: waiting for QuartusSetup-17.1.0.590

riaqn commented on 2018-01-27 14:21

hello @Sequencer,

I no longer maintain this pkg, but updating should be easy. Please feel free to do so and shot a pull request.

Sequencer commented on 2018-01-27 13:57

hello, quartus has update to 17.1, will this package update?

riaqn commented on 2017-04-11 03:08

Dear Projectgus, thanks for reminding me, please feel free to update the checksum as it changed.

Regarding the instructions: I don't have any reliable method to avoid manual intervention yet. I'm waiting for some volunteer to provide an Expect script.

projectgus commented on 2017-04-11 03:03

Ah, the manual step instructions that are printed out by the PKGFILE didn't show up for me. Maybe because I was using pacaur. So that might be why the installation seemed to hang (although as mentioned I also saw a hang in the GUI installer.)

projectgus commented on 2017-04-11 02:59

Thanks for packaging this. For some reason, the md5sums of the downloaded self-extracting archives seem to have changed:

$ md5sum *.run
d8a1730c18f2d79eb080786fffe2e203 QuartusSetup-16.1.0.196-linux.run
607e5cbff6b674034413e675655dda32 QuartusSetup-16.1.2.203-linux.run

I have no idea why Altera might have changed the packages without bumping the version numbers...

Unfortunately with these new archives the package installation also seems to hang after this output:
==> Starting package()...
installing the base of 16.1.0.196

The last process being run is:

QuartusSetup-16.1.2.203-linux.run --mode unattended --unattendedmodeui minimal --installdir .../pkg/quartus-standard//opt/altera

Running the GUI installer normally via "sudo ./QuartusSetup-16.1.0.196-linux.run" also hung at the moment that the .203 update installation finished (the popup .203 update window said "Finished" and then stopped refreshing). Cancelling the GUI installer and re-running with the 203 update disabled seemed to complete successfully.

Hope that helps someone. Ideally, I hope that some day an FPGA company will produce tools that aren't this horrible! :)

riaqn commented on 2017-02-16 09:16

TODO:

1. replace manual intervention with exepct script.
2. if you see "Inconsistency detected by ld.so: dl-close.c: 759: _dl_close: Assertion `map->l_init_called\' failed!", this problem has been discussed on internet, and the solution is to delete several shipped 3rd-party libraries like curl. In the future we will delete these .so files in the package and add these libraries as dependencies.