Package Details: qwtpolar 1.1.1-1

Git Clone URL: https://aur.archlinux.org/qwtpolar.git (read-only)
Package Base: qwtpolar
Description: Qwt library that contains classes for displaying values on a polar coordinate system
Upstream URL: http://qwtpolar.sourceforge.net/
Licenses: custom:qwt
Submitter: felixzero
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 44
Popularity: 3.177267
First Submitted: 2011-05-21 13:54
Last Updated: 2016-01-15 03:31

Latest Comments

saultdon commented on 2016-01-14 23:51

scimmia, it's been transferred to you =)

Scimmia commented on 2016-01-14 14:28

sautdon, I have no problem with you maintaining it; but if you'd rather not, I'd be willing to take over.

saultdon commented on 2016-01-06 21:33

@scimmia I can orphan if you'd like to be maintainer? I'm just not getting the time these days to give most packages the attention they need.

saultdon commented on 2015-10-27 22:45

@scimmia It fetches a branch of the current release with bugfixes.

Scimmia commented on 2015-10-24 04:11

saultdon, I think you misinterpreted the VCS_package_guidelines page. This isn't fetching a specific release.

dbr commented on 2015-07-26 20:27

@saultdon

Thanks so much for trying to help. This evening, everything works again and I was able to install qwtpolar through yaourt and I'm currently compiling qgis and very happy!

saultdon commented on 2015-07-26 08:44

@oxalin

I thought about adding -svn to the pkgname, but please see the first line for the guidelines at: https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines

saultdon commented on 2015-07-26 08:40

@dbr,oxalin

Sorry, but I can't reproduce those errors. It builds fine for myself... I'll have a look though.

dbr commented on 2015-07-25 09:34

I'm actually trying to install qgis which depends on qwtpolar and am running into problems because the sourceforge svn repos are offline.

Below I document my (somewhat hokey) partial success with a fail at the last hurdle.

1. Download qwtpolar-1.1.1.zip from http://sourceforge.net/projects/qwtpolar/

2. Following instructions from INSTALL: qmake - ran with no output, assume that is successful

3. make - got following error:

qwt_polar_fitter.h:13:30: fatal error: qwt_curve_fitter.h: No such file or directory

4. Following advice here and output of `whereis qwt`, I added the includepath to qwtpolarbuild.pri

`linux-g++ {
# CONFIG += separate_debug_info
INCLUDEPATH += /usr/include/qwt
}`

5. re-run make - now it at least gets further with compiling but now I get this error:

`collect2: error: ld returned 1 exit status
Makefile:228: recipe for target '../bin/spectrogram' failed
make[2]: *** [../bin/spectrogram] Error 1
make[2]: Leaving directory '/home/dbr/builds/qwtpolar-1.1.1/examples/spectrogram'
Makefile:43: recipe for target 'sub-spectrogram-make_first' failed
make[1]: *** [sub-spectrogram-make_first] Error 2
make[1]: Leaving directory '/home/dbr/builds/qwtpolar-1.1.1/examples'
Makefile:130: recipe for target 'sub-examples-make_first-ordered' failed
make: *** [sub-examples-make_first-ordered] Error 2
make 26.70s user 1.81s system 87% cpu 32.425 total`

6. I decided to comment out the examples by editing the line in qwtpolarconfig.pri
#QWT_POLAR_CONFIG += QwtPolarExamples

7. re-run make - don't get any errors

8. Looking at https://aur.archlinux.org/packages/qw/qwtpolar/PKGBUILD, I ran the sequence of sed commands to alter qwtpolarconfig.pri and qwtpolarbuild.pri

sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/doc/\/usr\/share\/doc\/qwt\//' qwtpolarconfig.pri
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/include/\/usr\/include\/qwt\//' qwtpolarconfig.pri
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/lib/\/usr\/lib\//' qwtpolarconfig.pri
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/features/\/usr\/share\/qwt\/features\//' qwtpolarconfig.pri
sed -i -e 's/^.*QwtPolarDesigner//' qwtpolarconfig.pri
sed -i -e 's/^.*QwtPolarExamples//' qwtpolarconfig.pri
echo "INCLUDEPATH += /usr/include" >> qwtpolarbuild.pri

I notice that this takes out the 'examples' line I did in step 6 - maybe should have done this first ;)

9. make install - no errors, but when I ask 'whereis qwtpolar', I
get 'qwtpolar:' which I take to mean that it isn't installed or
has gone to the wrong place and this hunch is confirmed by
performing `yainstall qgis` which lists 'qwtpolar' as a
dependency it has to install and this is the problem.

oxalin commented on 2015-07-20 18:58

Ok, after testing the installation, I think the problem in the lines identified in the previous comment comes from the "qwt" in the three following lines:
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/doc/\/usr\/share\/doc\/qwt\//' qwtpolarconfig.pri
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/include/\/usr\/include\/qwt\//' qwtpolarconfig.pri
[...]
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/features/\/usr\/share\/qwt\/features\//' qwtpolarconfig.pri


They should use "qwtpolar" instead:
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/doc/\/usr\/share\/doc\/qwtpolar\//' qwtpolarconfig.pri
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/include/\/usr\/include\/qwtpolar\//' qwtpolarconfig.pri
[...]
sed -i -e 's/$${QWT_POLAR_INSTALL_PREFIX}\/features/\/usr\/share\/qwtpolar\/features\//' qwtpolarconfig.pri

All comments