Package Details: r-maptools 1.1_1-1

Git Clone URL: https://aur.archlinux.org/r-maptools.git (read-only, click to copy)
Package Base: r-maptools
Description: Tools for Reading and Handling Spatial Objects
Upstream URL: http://cran.r-project.org/web/packages/maptools/index.html
Licenses: GPL
Submitter: hexd
Maintainer: hexd
Last Packager: hexd
Votes: 1
Popularity: 0.93
First Submitted: 2018-07-25 19:13
Last Updated: 2021-04-10 22:15

Dependencies (2)

Required by (8)

Sources (1)

Latest Comments

hcartiaux commented on 2021-04-08 11:54

Update available:

_cranver=1.1
_cranrel=1
sha256sums=('14a95dc56f51de7f64495f80761d13e2d13f0db2f4b0b50574d7d02c207fc45e')

dviktor commented on 2020-10-12 18:38

@gottgewollt version 1.0-2 is avail

gottgewollt commented on 2020-10-11 12:41

When I try to build r-maptools, I got the following error:

curl: (22) The requested URL returned error: 404 Not Found ==> FEHLER: Fehler beim Download von http://cran.r-project.org/src/contrib/maptools_0.9-9.tar.gz Breche ab... Fehler beim Erstellen von r-maptools

hexd commented on 2019-11-14 16:56

From https://wiki.archlinux.org/index.php/R_package_guidelines

R allows packages to have colons and hyphens in their version, this is disallowed in PKGBUILDs. Convert these to a period or underscore.

As the package version has both dot and hyphen, I'm using the underscore to avoid mixing these.

dviktor commented on 2019-10-10 11:44

I mean that according to Arch Wiki article it's recommended to use dot symbol instead of hyphen. A vast majority of AUR R packages use it (you can just check). All these packages use pkgver as in my previous comment. They don't use cranrel at all

hexd commented on 2019-10-06 21:23

Actually, _cranver has no "-" to be replaced by a dot. For now, I'm keeping the "_" to replace the "-" in the CRAN version. I can't keep the "-" since it's a forbidden character for the pkgver (it's the separator between the package "upstream content" version and the package release).

dviktor commented on 2019-09-30 15:07

Please use the following for pkgver:

pkgver=${_cranver//[:-]/.}