Package Details: r-sp 1.5.1-1

Git Clone URL: https://aur.archlinux.org/r-sp.git (read-only, click to copy)
Package Base: r-sp
Description: Classes and Methods for Spatial Data
Upstream URL: https://cran.r-project.org/package=sp
Licenses: GPL2, GPL3
Submitter: lysogeny
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 1
Popularity: 0.000005
First Submitted: 2018-06-09 10:28 (UTC)
Last Updated: 2022-11-13 18:01 (UTC)

Latest Comments

ragreener1 commented on 2022-06-08 12:36 (UTC)

You may wish to use this patch to update it. This adds the version constraints the dependencies. It also uses a snapshot from MRAN. This means that if the upstream is updated, then the package will still build before you update the PKGBUILD

From db01a49ba089645c0a2ddeecd6eb2c84fcf62b7e Mon Sep 17 00:00:00 2001
From: Robert Greener <me@r0bert.dev>
Date: Wed, 8 Jun 2022 13:35:18 +0100
Subject: [PATCH] Use MRAN and update to latest version

Signed-off-by: Robert Greener <me@r0bert.dev>
---
 .SRCINFO | 13 ++++++-------
 PKGBUILD | 12 +++++++-----
 2 files changed, 13 insertions(+), 12 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index 95b428a..9fe94f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
 pkgbase = r-sp
    pkgdesc = Classes and Methods for Spatial Data
-   pkgver = 1.4.7
+   pkgver = 1.5.0
    pkgrel = 1
    url = https://cran.r-project.org/package=sp
    arch = i686
    arch = x86_64
-   license = GPL2
-   license = GPL3
+   license = GPL
    depends = r>=3.0.0
    optdepends = r-rcolorbrewer
-   optdepends = r-rgdal
-   optdepends = r-rgeos
+   optdepends = r-rgdal>=1.2.3
+   optdepends = r-rgeos>=0.3.12
    optdepends = r-gstat
    optdepends = r-maptools
    optdepends = r-deldir
    optdepends = r-knitr
    optdepends = r-rmarkdown
-   source = https://cran.r-project.org/src/contrib/sp_1.4-7.tar.gz
-   sha256sums = 01946953707363b78d3eb8dcf472ea8c6ea0097094aa0ca0b756ce5fac01b1ad
+   source = https://cran.microsoft.com/snapshot/2022-06-08/src/contrib/sp_1.5-0.tar.gz
+   sha256sums = 939a06adf78ec8de7a663d6ca5bba426780852b357773446b00cc298200ff81c

 pkgname = r-sp
diff --git a/PKGBUILD b/PKGBUILD
index 9af3156..ba16aa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
 # Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
 # Contributor: Jooa <aur at (name) dot xyz>
+# Contributor: Robert Greener <me@r0bert.dev>

 _cranname=sp
-_cranver=1.4-7
+_cranver=1.5-0
+_updatedate=2022-06-08
 pkgname=r-${_cranname,,}
 pkgver=${_cranver//[:-]/.}
 pkgrel=1
 pkgdesc="Classes and Methods for Spatial Data"
 arch=(i686 x86_64)
 url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
+license=(GPL)
 depends=('r>=3.0.0')
-optdepends=(r-rcolorbrewer r-rgdal r-rgeos r-gstat r-maptools r-deldir r-knitr r-rmarkdown)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('01946953707363b78d3eb8dcf472ea8c6ea0097094aa0ca0b756ce5fac01b1ad')
+optdepends=(r-rcolorbrewer "r-rgdal>=1.2.3" "r-rgeos>=0.3.12" r-gstat r-maptools r-deldir r-knitr r-rmarkdown)
+source=("https://cran.microsoft.com/snapshot/${_updatedate}/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('939a06adf78ec8de7a663d6ca5bba426780852b357773446b00cc298200ff81c')

 build() {
   R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
-- 
2.36.1

dviktor commented on 2021-12-08 18:19 (UTC)

Further maintenance and support for this package has been moved there. You can install pre-built packages from my repo