Package Details: rabbitvcs-thunar 0.16-1

Git Clone URL: https://aur.archlinux.org/rabbitvcs-thunar.git (read-only)
Package Base: rabbitvcs-thunar
Description: Thunar front-end for RabbitVCS
Upstream URL: http://rabbitvcs.org/
Licenses: GPL
Submitter: dimka
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 30
Popularity: 0.008253
First Submitted: 2010-02-13 16:35
Last Updated: 2015-06-08 10:26

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

dcelasun commented on 2014-05-07 07:43

Updated to v0.16.

Jristz commented on 2014-04-25 22:46

the page say rabitcvs 0.16.0 is out
*Arch guidelines say not use the last .0 unless is really necesary (like in o.18.0.1 but not in 0.18.0)

doragasu commented on 2013-10-30 09:38

Does this support showing emblems on Thunar? It looks like it don't...

dcelasun commented on 2012-07-16 07:44

Package updated to 0.15.0.5.

Anonymous comment on 2012-05-01 22:05

Hi, I upgraded the PKGBUILD to install rabbitvcs-thunar version 0.15.0.5.
Instructions:
- Create a directory e.g. rabbitvcs-thunar-0.15.0.5
- Paste the following text (starting from #Contributor) to a file called PKGCONFIG
- makepkg
- sudo pacman -U rabbitvcs-thunar-0.15.0.5-1-i686.pkg.tar.xz
(for i686)
I was first surprised how small the package got, but it contains really just the thunar plugin of rabbitvcs.
Enjoy!


#Contributor: Dmitry Batenkov <dima dot batenkov at gmail dot com>

pkgname=rabbitvcs-thunar
#pkgver=0.14.2.1
pkgver=0.15.0.5
#pkgrel=2
pkgrel=1
pkgdesc="Thunar front-end for RabbitVCS"
arch=('i686' 'x86_64')
url="http://rabbitvcs.org/"
#depends=('thunar>=0.4.0' 'thunarx-python>=0.2.0' 'dbus-python>=0.80' 'rabbitvcs>=${pkgver}')
depends=('thunar>=0.4.0' 'thunarx-python>=0.2.0' 'dbus-python>=0.80' "rabbitvcs>=${pkgver}")
license=('GPL')
#source=(http://rabbitvcs.googlecode.com/files/rabbitvcs-${pkgver}.tar.gz)
source=(http://rabbitvcs.googlecode.com/files/rabbitvcs-${pkgver}.tar.bz2)
#md5sums=('db6f73014639d93653f3e2af2b0ed11f')
sha1sums=('a9e1e741a3e665e3ce2769b2730fafde26955b53')

build(){
cd ${srcdir}/rabbitvcs-${pkgver} || return 1
mkdir -p $pkgdir/usr/lib/thunarx-2/python || return 1
mkdir -p $pkgdir/usr/lib/thunarx-1/python || return 1
sed -i '1i #!/usr/bin/env python2' clients/thunar/RabbitVCS.py
cp clients/thunar/RabbitVCS.py $pkgdir/usr/lib/thunarx-2/python || return 1
cp clients/thunar/RabbitVCS.py $pkgdir/usr/lib/thunarx-1/python || return 1
}

gbc921 commented on 2012-03-23 20:56

@max-k
Could you please post the updated PKGBUILD again? The link is empty. (Maybe the option to keep the post just for one month was selected).

Cheers,

max-k commented on 2012-02-06 15:21

Here is an updated PKGBUILD to use with thunarx-python 0.3.0 : http://pastebin.archlinux.fr/437598

max-k commented on 2012-02-06 10:41

Here is an updated PKGBUILD (0.15.0.5):
http://pastebin.archlinux.fr/437595

Anonymous comment on 2011-04-13 12:42

I don't think you can have ${pkgver} inside of quotations it should be 'rabbitvcs>='${pkgver} or just 'rabbitvcs>=0.14.2.1' fails to build otherwise.

Anonymous comment on 2011-04-10 10:26

Error in PKGBUILD.

Here is patch:

9c9
< depends=('thunar>=0.4.0' 'thunarx-python>=0.2.0' 'dbus-python>=0.80' 'rabbitvcs>=${pkgver}')
---
> depends=('thunar>=0.4.0' 'thunarx-python>=0.2.0' 'dbus-python>=0.80' "rabbitvcs>=${pkgver}")

DarwinSurvivor commented on 2010-04-11 23:12

Oops, my bad, I had a previous instance of thunar running so it was just spawning a new window instead of reloading the application :P

DarwinSurvivor commented on 2010-04-11 23:10

After installing this package, thunar does not show any changes. The context menu also is unaffected.