Package Details: racket-git 7.0.0.12.38897.369eb65ec2-1

Git Clone URL: https://aur.archlinux.org/racket-git.git (read-only)
Package Base: racket-git
Description: Minimal Racket installation, without DrRacket, from git
Upstream URL: http://racket-lang.org/
Licenses: LGPL
Conflicts: racket
Provides: racket
Submitter: None
Maintainer: banzr
Last Packager: haawda
Votes: 1
Popularity: 0.000000
First Submitted: 2010-12-10 15:10
Last Updated: 2018-08-17 21:03

Required by (5)

Sources (1)

Latest Comments

1 2 Next › Last »

pmatos commented on 2018-05-13 12:24

Ah, thanks, I didn't notice there was already a racket package in community.

haawda commented on 2018-05-12 19:58

The racket package in [community] includes drracket, so providing a non-git version of drracket would be kind of a duplicate. I don't mind if you provide a drracket-git package.

pmatos commented on 2018-05-12 17:11

Thanks. I would like to add packages for drracket 6.12 and git. Is this something you want to do yourself since you own racket-git, or are you happy for me to do it?

Apologies but I just started using arch so I am not familiar with package ownership policies.

haawda commented on 2018-05-11 18:14

Updated

haawda commented on 2018-05-11 10:49

The URL git://github.com/plt/racket.git is redirected for me to git://github.com/racket/racket.git

But I will change it when I am back at my Arch box.

pmatos commented on 2018-05-11 10:15

Also, the url listed in sources git://github.com/plt/racket.git does not exist. It's github.com/racket/racket.git

pmatos commented on 2018-05-11 10:15

Was confused by the version number: 6.11.0.5.38300.36d563d7ce-1

Current stable is 6.12 and git HEAD is 6.90 at least.

haawda commented on 2018-05-11 09:42

There is no update needed. This is a git-package, so running makepkg will always fetch the newest sources from master. Updating without a reason is forbidden by the AUR-Guidelines.

pmatos commented on 2018-05-11 09:24

Are you thinking about updating this package?

carlmax commented on 2014-01-04 03:15

For the 5.3.6 version, please apply this patch on PKGBUILD:

--- PKGBUILD.orig 2010-12-10 23:12:06.000000000 +0800
+++ PKGBUILD 2014-01-04 19:11:46.239900431 +0800
@@ -35,7 +35,7 @@
rm -rf ${_gitname}-build
git clone ${_gitname} ${_gitname}-build

- cd ${srcdir}/${_gitname}-build/src
+ cd ${srcdir}/${_gitname}-build/racket/src

./configure --prefix=/usr
make
@@ -44,9 +44,9 @@

package() {
echo ${PWD}
- cd ${srcdir}/${_gitname}-build/src
+ cd ${srcdir}/${_gitname}-build/racket/src
echo ${PWD}
make DESTDIR="${pkgdir}" install
- install -D -m644 ../collects/icons/plt.xpm "${pkgdir}/usr/share/pixmaps/drracket.xpm"
+ install -D -m644 ../../pkgs/icons/plt.xpm "${pkgdir}/usr/share/pixmaps/drracket.xpm"
# install -D -m644 "${srcdir}/drracket.desktop" "${pkgdir}/usr/share/applications/drracket.desktop"
}