Package Details: radare2-bindings 2.8.0-1

Git Clone URL: https://aur.archlinux.org/radare2-bindings.git (read-only)
Package Base: radare2-bindings
Description: Language bindings of the radare2 api for valabind and friends
Upstream URL: http://radare.org
Licenses: GPL3
Submitter: anthraxx
Maintainer: anthraxx
Last Packager: anthraxx
Votes: 29
Popularity: 0.000000
First Submitted: 2015-07-05 12:41
Last Updated: 2018-08-08 21:06

Latest Comments

1 2 Next › Last »

orson commented on 2019-05-17 15:12

@Muhaha You need to update 'pkgver' field in PKGBUILD, so it matches the installed radare2 version. It also requires updating the checksums (or replacing the hash values with 'skip').

Muhaha commented on 2018-11-22 02:45

The package doesn't build :(

make[1]: [Makefile:72: lang_python.so] Error 1 make[1]: Leaving directory '/tmp/trizen-dennis/radare2-bindings/src/radare2-bindings-2.8.0/libr/lang/p' make: [Makefile:46: all] Error 2

igormp commented on 2018-01-12 04:53

Looks like it has finally been fixed in git, any news when this package will be updated?

anthraxx commented on 2017-10-15 21:19

there won't be any radare2-bindings until valabind is fixed but that can only be done from gnome vala side:
https://github.com/radare/valabind/issues/43

hcorion commented on 2017-06-15 23:37

I would appreciate these being updated!

flacks commented on 2016-09-29 16:50

Building version 0.10.6 against radare2 0.10.6 is successful

dmidge commented on 2016-09-29 02:25

I had the same problem than tahayassen. I solved it by installing the 0.10.5-1, which is also my radare2 version. Maybe these two packages need to be synchronize in the version? Because the 0.10.6-1 radare2-bindings version gives me the same "install-python" error, so it is not a bug that has been solved by a newer version...

anthraxx commented on 2016-04-14 13:28

@tahayassen: I can't tell you anything about manjaro environment, but make sure that you have valabind 0.10.0-2 and radare2 0.10.2-1. Especially make sure to have the -2 version of valabind.

tahayassen commented on 2016-04-13 01:41

0.10.2 doesn't appear to compile on my system. I get a "recipe for target 'install-python' failed" error. 0.10.1 worked for me.

This is probably because I am running Manjaro and the radare2 version is still 0.10.1.

sinatosk commented on 2016-03-02 10:34

Validating source file with sha512sums radare2-bindings-0.10.1.tar.gz fails