Package Details: ragel-dev 7.0.0.10-2

Git Clone URL: https://aur.archlinux.org/ragel-dev.git (read-only)
Package Base: ragel-dev
Description: Compiles finite state machines from regular languages into executable C, C++, Objective-C, C#, ASM, D, Go, Java, Ruby, OCaml, Crack, Rust or Julia code.
Upstream URL: http://www.complang.org/ragel/
Licenses: GPL
Conflicts: ragel
Submitter: computerquip
Maintainer: bacondropped
Last Packager: bacondropped
Votes: 1
Popularity: 0.000000
First Submitted: 2015-12-10 02:32
Last Updated: 2017-07-13 00:39

Latest Comments

bacondropped commented on 2017-07-14 23:54

Ugh. Ragel 7.0.0.10 hard-depends both on ragel v7.0.0.9 (there's a compile error otherwise) and on colm v0.13.0.5 (in the configure stage), but ragel v7.0.0.9 hard-depends on colm v0.13.0.4. So far the only way to compile that I see is to install colm 0.13.0.5 .so by hand alongside 0.13.0.4 and build ragel 7.0.0.10 with 7.0.0.9 (not easily packageable). Stand by for updates.

computerquip commented on 2016-12-15 18:41

I'll drop the package. Author of ragel is a jerk and I won't use it anymore.

bacondropped commented on 2016-12-05 05:21

Follow-up to my 7.0.0.9 flag: it now requires colm, which I have packaged: https://aur.archlinux.org/packages/colm/. I'll follow it up with a colm-dev today, which you should be able to require in the PKGBUILD.

UPDATE: ragel-dev 7.0.0.9 builds successfully with colm-dev v0.13.0.4. Here's the package patch: https://gist.github.com/bacondropped/3900b2d69c2ab1b7523ba5057b324c71