Package Details: rambox 0.7.5-2

Git Clone URL: https://aur.archlinux.org/rambox.git (read-only, click to copy)
Package Base: rambox
Description: Free and Open Source messaging and emailing app that combines common web applications into one.
Upstream URL: https://rambox.pro/
Licenses: GPL3
Submitter: flying-sheep
Maintainer: masterkorp
Last Packager: TheGoliath
Votes: 15
Popularity: 0.29
First Submitted: 2017-05-23 23:11
Last Updated: 2020-06-15 11:32

Pinned Comments

TheGoliath commented on 2020-05-28 12:33

I've updated the package to version 0.7.5. Feel free to comment down below if anything doesn't work as expected or related :) In the meantime, happy chatting!

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

noraj commented on 2018-02-27 18:29

About URL with v : it seems that was always without v before and it is without now, it was maybe a weird temporary bug, but I think you need to change it back.

About env.js : you may download it manually and then provide env.js in sources like rambox.desktop or rambox.js?

About sencha : I didn't know, I was just asking if it was possible.

PS : I send you a mail with the working and tested patch

flying-sheep commented on 2018-02-27 09:06

Yesterday I had to change the URL from the one without “v” to the one with “v” >:( Seems like there’s some changes being made…

About env.js: Where is an env.js with the API key other than in the binary package? I can only stop downloading it once I can get the API key another way.

About sencha: The Rambox author chose it as build system. I’m not going to figure out how to build the whole monstrosity without it ;)

noraj commented on 2018-02-26 23:33

0.5.15 build is failing

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/saenzramiro/rambox/releases/download/v0.5.15/Rambox-0.5.15-x64.tar.gz
    Aborting...
==> ERROR: Makepkg was unable to build .

because url is not

https://github.com/saenzramiro/rambox/releases/download/v0.5.15/Rambox-0.5.15-x64.tar.gz

but

https://github.com/saenzramiro/rambox/releases/download/0.5.15/Rambox-0.5.15-x64.tar.gz

without the "v" before "0.5.15".

Also sha256 hash of 0.5.15.tar.gz fro marchive is not good:

$ sha256sum 0.5.15.tar.gz
dacccd6b9ed847f351a8dfbe1eee45c9adf3826aba57fb4eefa2c39ebaf69175  0.5.15.tar.gz

instead of ae35c4b8e0ae24449fdaf480c7000a2fd5b6e6e721f99afcb942f1b898f1268c expected.

noraj commented on 2018-02-26 23:21

please, is that possible to avoid using the commercial sencha-cmd-6 dependency ?

Also you shouldn't download the binary package in the source rambox AUR package there is already rambox-bin for that. You don't need "Rambox-$pkgver-x64.tar.gz" to get env.js.

flying-sheep commented on 2018-02-02 15:13

Weird, for me it works!

StephenBrown2 commented on 2018-02-01 16:12

@twa022 Unfortunately your sencha-cmd-6.1 is now too new still, as I'm getting the following when trying to build rambox after installing aur/sencha-cmd-6.1 6.1.3-1:

Sencha Cmd v6.1.3.42
[INF] Using GPL version of Ext JS version 5.1.1.451 from /home/stephen/.cache/pacaur/rambox/src/rambox-0.5.14/ext.
[INF] The implications of using GPL version can be found here (http://www.sencha.com/products/extjs/licensing).
[INF] Processing Build Descriptor : default
[WRN] the following remote package repository directories did not initialize properly :
[WRN]    - /opt/Sencha/repo/.sencha
[WRN]    - /opt/Sencha/repo/pkgs
[ERR] javax/xml/bind/DatatypeConverter
[ERR] 
The application was last modified by an older version of Sencha Cmd (6.1.2.15)
the current is 6.1.3.42.
Please run "sencha app upgrade" to update to 6.1.3.42.

twa022 commented on 2018-01-07 00:12

I had to use sencha-cmd 6.1.x to successfully compile the package. So I added a package to the AUR: sencha-cmd-6.1

This is what I get trying to compile using the current version of sencha-cmd:

Sencha Cmd v6.5.2.15 [INF] Using GPL version of Ext JS version 5.1.1.451 from /home/xxxxxxx/Downloads/rambox/src/rambox-0.5.13/ext. [INF] The implications of using GPL version can be found here (http://www.sencha.com/products/extjs/licensing). [INF] Processing Build Descriptor : default (production environment) [ERR] javax/xml/bind/DatatypeConverter [ERR] [ERR] The application was last modified by an older version of Sencha Cmd (6.1.2.15). [ERR] Running "sencha app upgrade" may resolve the error described above. [ERR] npm ERR! code ELIFECYCLE npm ERR! errno 65 npm ERR! @ sencha:compile: sencha app build && cp app/package.json build/production/Rambox/ && npm --prefix ./build/production/Rambox/ install ./build/production/Rambox/

and when I try to run sencha app upgrade:

Sencha Cmd v6.5.2.15 [INF] Upgrading to Ext JS 5.x [INF] Upgrading to sdk at /home/xxxxxxxx/Downloads/rambox/src/rambox-0.5.13/ext [INF] Updating application and workspace from Ext JS 5.1.1.451 / Cmd 6.1.2.15

[ERR] /opt/Sencha/Cmd/plugins/ext/5.1/plugin.xml:382: com.sencha.exceptions.ExScript: Wrapped com.sencha.exceptions.BasicException: javax/xml/bind/DatatypeConverter (/opt/Sencha/Cmd/ant/ant-util.js#849) runSencha (/opt/Sencha/Cmd/ant/ant-util.js:848) runAppUpgrade (anonymous:409) [anonymous] (anonymous:419) x_app_upgrade (anonymous:418) [ERR] A log is available in the file "/home/xxxxxxxx/Downloads/rambox/src/rambox-0.5.13/sencha-error-20180106.log" [ERR] [ERR] The application was last modified by an older version of Sencha Cmd (6.1.2.15). [ERR] Running "sencha app upgrade" may resolve the error described above. [ERR]

flying-sheep commented on 2017-11-22 14:46

please delete the patch and redownload it, you still have the old one.

should have given the patch some version number in the filename…

undu commented on 2017-11-22 13:26

In my case, the md5 for the downloaded file 'context-menu.patch' is '953d6b589b7acee32d78da6c533e851bc90a11182b775388ddcf158decf66c8e'

The file seems to be a well-formed patch.

:/

flying-sheep commented on 2017-11-21 11:34

thanks, fixed!