Package Details: rambox 0.7.5-2

Git Clone URL: https://aur.archlinux.org/rambox.git (read-only, click to copy)
Package Base: rambox
Description: Free and Open Source messaging and emailing app that combines common web applications into one.
Upstream URL: https://rambox.pro/
Licenses: GPL3
Submitter: flying-sheep
Maintainer: masterkorp
Last Packager: TheGoliath
Votes: 15
Popularity: 0.30
First Submitted: 2017-05-23 23:11
Last Updated: 2020-06-15 11:32

Pinned Comments

TheGoliath commented on 2020-05-28 12:33

I've updated the package to version 0.7.5. Feel free to comment down below if anything doesn't work as expected or related :) In the meantime, happy chatting!

Latest Comments

« First ‹ Previous 1 2 3 4 5

Andrwe commented on 2017-11-21 11:20

Hi,

I got an checksum mismatch for context-menu.patch.
By replacing '953d6b589b7acee32d78da6c533e851bc90a11182b775388ddcf158decf66c8e' with '3b1c0c47d5d5e46eba7c9a3f92dac18b6378c1f41386602b8f285b506b3c4906' the mismatch is fixed.

flying-sheep commented on 2017-09-28 08:18

the relevant lines are:

22 error @ sencha:compile: `sencha app build && cp app/package.json build/production/Rambox/ && npm --prefix ./build/production/Rambox/ install ./build/production/Rambox/`
22 error Exit status 65

i have no idea which of those failed and what exit code 65 means. you?

danerd commented on 2017-09-27 05:34

I get following error messeage:
npm ERR! Failed at the @ sencha:compile script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/pada/.npm/_logs/2017-09-27T05_28_20_088Z-debug.log
------
Here is the logfile: https://ghostbin.com/paste/uow9msfs PW:danerd

flying-sheep commented on 2017-09-18 12:14

yes, it’s 0.5.11. sorry: https://github.com/saenzramiro/rambox/issues/1124

danalec commented on 2017-09-18 01:40

0.5.12-2: for some reason it still displays as 0.5.11 and using older chromium 56.0.2924.87

flying-sheep commented on 2017-09-07 10:10

The checksum is correct, as I changed the patch.

Please delete the file and try again.

tikrass commented on 2017-09-07 09:42

The check for context-menu.patch fails. After updating checksums manually, the patch fails:

patching file app/package.json
Hunk #1 FAILED at 35.
1 out of 1 hunk FAILED -- saving rejects to file app/package.json.rej

patching file package.json
Hunk #1 FAILED at 106.
1 out of 1 hunk FAILED -- saving rejects to file package.json.rej

twa022 commented on 2017-05-30 16:02

Could you add npm to the makedepends. Build fails without it.

flying-sheep commented on 2017-05-29 14:59

the second one is just for some API keys that rambox needs to run.

i was too lazy to apply for my own, and didn’t want to host the official ones in plaintext somewhere, but instead extract them from a binary package.

you’re right, the newest release doesn’t have binary packages yet, so i need to use the env.js from an older one.

xarinatan commented on 2017-05-27 19:42

Heya, the second source, https://github.com/saenzramiro/rambox/releases/download/0.5.8/Rambox-0.5.8-x64.tar.gz , seems to give a 404.
Is this file really needed? isn't the first one enough? On Github only the first one is displayed, but I could be mistaken because I personally haven't compiled this before.