Package Details: randrproto-git 1.5.0.r159.g98da0d6-1

Git Clone URL: https://aur.archlinux.org/randrproto-git.git (read-only)
Package Base: randrproto-git
Description: X11 RandR extension wire protocol - Git version
Upstream URL: http://cgit.freedesktop.org/xorg/proto/randrproto/
Licenses: custom
Conflicts: randrproto
Provides: randrproto=1.5.0.r159.g98da0d6
Submitter: Det
Maintainer: Det
Last Packager: Det
Votes: 4
Popularity: 0.000028
First Submitted: 2010-12-07 20:45
Last Updated: 2015-06-14 01:18

Dependencies (2)

Required by (59)

Sources (1)

Latest Comments

Det commented on 2015-04-30 20:22

We'll see how this goes:

pkgver() {
 cd $_pkgname

 # Git might not be tagged appropriately, sources (hopefully) are
 _ver1=$(git describe --long | cut -d "-" -f2-3 | tr - .).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)
 _ver2=$(grep AC_INIT configure.ac | cut -d "[" -f3 | cut -d "]" -f1).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)

 # Choose higher
 if [[ $(vercmp $_ver1 $_ver2) = 1 ]]; then
  echo $_ver1
 else
  echo $_ver2
 fi
}

jamesan commented on 2015-04-30 06:53

The upstream package has its version 1.5.0 release in March 30, but the repo doesn't have a tag for that version yet even though its source files reflect that new version and downstream packages have begun requiring this new version for their new releases.

The pkgver() will underreport the version until a release tag exists, so should it be disabled until then? I've published these changes in a diff you can find here:

https://github.com/jamesan/aur-pkgs/commit/b837dcbeed850e7432929c47bf323c971b0656bb