Package Details: rapidminer-studio 10.1.1-1

Git Clone URL: https://aur.archlinux.org/rapidminer-studio.git (read-only, click to copy)
Package Base: rapidminer-studio
Description: RapidMiner is the enterprise-ready data science platform
Upstream URL: https://rapidminer.com/platform/
Keywords: analytics data maschinelearning ml modeling predict science
Licenses: AGPL3
Submitter: efernandes
Maintainer: Varakh
Last Packager: Varakh
Votes: 9
Popularity: 0.021890
First Submitted: 2016-03-26 18:17 (UTC)
Last Updated: 2023-02-01 22:47 (UTC)

Dependencies (4)

Required by (0)

Sources (2)

Pinned Comments

Varakh commented on 2022-08-06 13:30 (UTC) (edited on 2022-11-28 23:40 (UTC) by Varakh)

This package requires Java 11. AUR interface shows the java-runtime=11 and java-environment=11 version constraints incorrectly.

Latest Comments

1 2 Next › Last »

Varakh commented on 2022-11-28 23:42 (UTC) (edited on 2022-11-29 00:04 (UTC) by Varakh)

There has been a major version update to RapidMiner Studio. This package will serve the latest. If there's a need to maintain the legacy Java 8 based 9.x releases, please let me know in the comments and we might come up with rapidminer-studio-legacy or something.

Varakh commented on 2022-08-06 13:30 (UTC) (edited on 2022-11-28 23:40 (UTC) by Varakh)

This package requires Java 11. AUR interface shows the java-runtime=11 and java-environment=11 version constraints incorrectly.

nobicycle commented on 2022-08-03 02:50 (UTC)

(thanks for packaging)

$ JAVA="/usr/lib/jvm/java-8-openjdk/jre/bin/java" rapidminer-studio

[user@tower tmp]$ ls -l /usr/lib/jvm/java-8-openjdk/jre/bin/java -rwxr-xr-x 1 root root 14416 Jul 23 23:55 /usr/lib/jvm/java-8-openjdk/jre/bin/java

[user@tower tmp]$ JAVA="/usr/lib/jvm/java-8-openjdk/jre/bin/java" rapidminer-studio Aug 03, 2022 10:48:59 AM com.rapidminer.tools.PlatformUtilities logInfo INFO: Searching in Java classpath for RapidMiner Studio jars... Aug 03, 2022 10:48:59 AM com.rapidminer.tools.PlatformUtilities logInfo INFO: Trying parent directory of '/opt/rapidminer-studio/lib/rapidminer-studio-core-9.10.10.jar'... Aug 03, 2022 10:48:59 AM com.rapidminer.tools.PlatformUtilities logInfo INFO: Gotcha! 'rapidminer.home' is: /opt/rapidminer-studio Aug 03, 2022 10:48:59 AM com.rapidminer.tools.PlatformUtilities logInfo INFO: Release platform: ANY Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter at com.rapidminer.license.verification.JarVerifier.createPublicKey(JarVerifier.java:270) at com.rapidminer.license.verification.JarVerifier.<clinit>(JarVerifier.java:140) at com.rapidminer.launcher.GUILauncher.main(GUILauncher.java:287) Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:641) at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:188) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) ... 3 more

haeloath commented on 2021-01-23 17:39 (UTC) (edited on 2021-01-23 17:42 (UTC) by haeloath)

You can force the app to launch with java 8 without setting it to default. Add this line to the file "/opt/rapidminer-studio/RapidMiner-Studio.sh"

JAVA="/usr/lib/jvm/java-8-openjdk/bin/java"

You need to add this line before

Launch RapidMiner and check for updates

block in the file. Obviously java 8 is still needed for this to work.

khalil2535 commented on 2020-10-22 08:53 (UTC)

==> ERROR: One or more files did not pass the validity check!

devrfc83 commented on 2020-06-09 14:46 (UTC) (edited on 2020-06-09 19:20 (UTC) by devrfc83)

I recovered my ArchLinux machine last Saturday, and got notified about the update requests. Unfortunately I had my keys on that machine and my backup on another one, but now RapidMiner Studio is updated to 9.7 rel 1 and Varakh is added as a co-maintainer.

I apologize for the delay.

rhynzler commented on 2020-03-26 03:46 (UTC) (edited on 2020-03-26 03:47 (UTC) by rhynzler)

If someone has problems to build, There are a new version of rapidminer, so this causes a failure. To be able to install, just edit the PKGBUILD to: Line 5:

pkgver=9.6.0
and place
sha256sums=('2b235c30e4c6a74c525ae04004c1d706b3213618b1d18f9650f5ad0f7e465a5c'
            'd3d76353c1ae15eec44c2fc638bbde98a192b70447bd467763f6d41cf24b6e5a')
on line 15.

FunctionalHacker commented on 2020-01-22 09:13 (UTC)

I get java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter if I try to run it on the latest OpenJDK. I found out that this class is not found in the classpath anymore after java 8. Solved by installing openjdk8-jre and setting that as default