Package Details: rapidminer-studio 9.10.1-1

Git Clone URL: https://aur.archlinux.org/rapidminer-studio.git (read-only, click to copy)
Package Base: rapidminer-studio
Description: Real data science, fast and simple. Reinvents enterprise AI so that anyone has the power to positively shape the future. Empowers data scientists and business analysts to effortlessly design predictive analytics from mashup to modeling to deployment.
Upstream URL: https://rapidminer.com/products/studio/
Keywords: analytics modeling predict
Licenses: AGPL3
Submitter: efernandes
Maintainer: devrfc83 (Varakh)
Last Packager: Varakh
Votes: 8
Popularity: 0.000240
First Submitted: 2016-03-26 18:17
Last Updated: 2021-10-22 15:39

Dependencies (3)

Required by (0)

Sources (2)

Latest Comments

haeloath commented on 2021-01-23 17:39

You can force the app to launch with java 8 without setting it to default. Add this line to the file "/opt/rapidminer-studio/RapidMiner-Studio.sh"

JAVA="/usr/lib/jvm/java-8-openjdk/bin/java"

You need to add this line before

Launch RapidMiner and check for updates

block in the file. Obviously java 8 is still needed for this to work.

khalil2535 commented on 2020-10-22 08:53

==> ERROR: One or more files did not pass the validity check!

devrfc83 commented on 2020-06-09 14:46

I recovered my ArchLinux machine last Saturday, and got notified about the update requests. Unfortunately I had my keys on that machine and my backup on another one, but now RapidMiner Studio is updated to 9.7 rel 1 and Varakh is added as a co-maintainer.

I apologize for the delay.

rhynzler commented on 2020-03-26 03:46

If someone has problems to build, There are a new version of rapidminer, so this causes a failure. To be able to install, just edit the PKGBUILD to: Line 5:

pkgver=9.6.0
and place
sha256sums=('2b235c30e4c6a74c525ae04004c1d706b3213618b1d18f9650f5ad0f7e465a5c'
            'd3d76353c1ae15eec44c2fc638bbde98a192b70447bd467763f6d41cf24b6e5a')
on line 15.

FunctionalHacker commented on 2020-01-22 09:13

I get java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter if I try to run it on the latest OpenJDK. I found out that this class is not found in the classpath anymore after java 8. Solved by installing openjdk8-jre and setting that as default

devrfc83 commented on 2019-12-11 13:26

Hello banshee,

Yes, the PKGBUILD file uses the latest version of RapidMiner Studio instead of a specific version. To be able to install, just edit the PKGBUILD to:

Line 5: pkgver=9.5.1

And place the output of $ sha256sum rapidminer-studio.zip on line 16.

I notified the developer and updated my own repository to be able to install.

Disclaimer: I work with RapidMiner.

banshee commented on 2019-12-11 12:55

Unable to update package.

==> Validating source files with sha256sums...

rapidminer-studio.zip ... FAILED

rapidminer-studio.sh ... Passed

==> ERROR: One or more files did not pass the validity check!

==> ERROR: Makepkg was unable to build rapidminer-studio.

efernandes commented on 2019-11-18 18:56

Thank you @dev-rfc83

In the coming days, I'll update deps to ensure the use of java 8.

devrfc83 commented on 2019-11-16 01:41

Hello, World.

For better support, ensure you use OpenJDK 8 with RapidMiner Studio and "not" OpenJDK 9+ until the team begins the migration path. Unfortunately some third party libraries used by RapidMiner Studio are broken for Java 9+.

All the best,

Rodrigo Fuentealba.