Package Details: rare 1.4.1-1

Git Clone URL: https://aur.archlinux.org/rare.git (read-only, click to copy)
Package Base: rare
Description: A GUI for legendary, an open source replacement for Epic Games Launcher
Upstream URL: https://github.com/Dummerle/Rare
Keywords: epic-games game-launcher games legendary
Licenses: GPL3
Submitter: Dummerle
Maintainer: Dummerle
Last Packager: Dummerle
Votes: 3
Popularity: 0.39
First Submitted: 2021-03-14 14:18
Last Updated: 2021-05-18 13:35

Latest Comments

peoro commented on 2021-03-16 13:53

Thanks again for the very quick fix!

rare still crashes due to the missing icon mdi.view-grid-outline.

I looked a bit into that and noticed that the python-qtawesome package in arch's community repo is version 0.6.0 (while the latest upstream version is 1.0.2; the package has been flagged out of date for months, apparently).

python-qtawesome 0.6.0 was using mdi 3.8.95 which didn't include a view-grid-outline icon.

Replacing "mdi.view-grid-outline" with "mdi.view-grid" in Rare/utils/QtExtensions.py (lines 228 and 234) fixed the issue.

I'm not sure what the best solution could be. But the quickest one is to run a sed -i 's/mdi.view-grid-outline/mdi.view-grid/' $srcdir/Rare-$pkgver/Rare/utils/QtExtensions.py in the pkgbuild's prepare function.

peoro commented on 2021-03-16 04:26

Thanks for fixing the missing dependency. A couple more things:

  • rare still crashes on my system: Exception: Invalid icon name "view-grid-outline" in font "mdi" (raised by qtawesome, called at /usr/lib/python3.9/site-packages/Rare/utils/QtExtensions.py:209)

  • gendesk should be listed as a dev dependency, since it's used to build the package.

  • legendary should be listed in the conflicts and provides arrays, since this package embeds a fork of legendary.

peoro commented on 2021-03-14 16:55

It doesn't run:

ModuleNotFoundError: No module named 'notifypy'