Package Details: ratpoison-jcs-git 1.4.6-1

Git Clone URL: https://aur.archlinux.org/ratpoison-jcs-git.git (read-only)
Package Base: ratpoison-jcs-git
Description: hacks atop the official ratpoison
Upstream URL: https://github.com/jcs/ratpoison
Licenses: GPL
Conflicts: ratpoison
Submitter: odknt
Maintainer: odknt
Last Packager: odknt
Votes: 0
Popularity: 0.000000
First Submitted: 2016-08-11 06:47
Last Updated: 2016-08-11 07:05

Latest Comments

dreieck commented on 2018-01-28 12:52

The PKGBUILD with all the fixes I mentioned in the messages below can be found there:

http://ix.io/EOh

And just a patch against the AUR PKGBUILD:

http://ix.io/EOg

Note, that I added a few more things in the PKGBUILD (explicit options to ./configure, installation of informational files into /usr/share/doc/${_pkgname}).

dreieck commented on 2018-01-28 12:36

'libxrandr' needs to be added to the depends-array.

dreieck commented on 2018-01-28 12:35

The stanza rm "${pkgdir}/usr/share/ratpoison/ratpoison.el" needs to be removed from the PKGBUILD's package()-function. The error message is:

rm: cannot remove '[...]/ratpoison-jcs-git/pkg/ratpoison-jcs-git/usr/share/ratpoison/ratpoison.el': No such file or directory ==> ERROR: A failure occurred in package(). Aborting...

dreieck commented on 2018-01-28 12:28

Note that after downloading the source, ./configure is not available yet. It is necessary to run ./autogen.sh before, which is not done by your PKGBUILD now.

Needs fixing.

I suggest to put ./autogen.sh --verbose into the function prepare().

dreieck commented on 2018-01-28 12:01

Upstream ist at least at version 1.4.9 now.

Your PKGBUILD downloads the latest version (git checkout), but you have a fixed pkgver.

You should add a pkgver()-function which outputs to it's stdout the actual pkgver (+ git-"revision") to keep the pkgver variable up to date.

For me, this function does it:

http://ix.io/EOa

.. and, also, in the PKGBUILD I defined _pkgver=latest pkgver="${_pkgver}"

and an invocation of pkgver(), which makepkg does automativally, will re-write pkgver= in the PKGBUILD to the correct value.

dreieck commented on 2018-01-28 11:15

Can you add

provides=("${_pkgname}=${pkgver}")

to the PKGBUILD?