Package Details: rcssmonitor 15.1.1-1

Git Clone URL: https://aur.archlinux.org/rcssmonitor.git (read-only)
Package Base: rcssmonitor
Description: The RoboCup 2D Soccer Simulator Monitor.
Upstream URL: https://sourceforge.net/apps/mediawiki/sserver/index.php?title=Main_Page
Licenses: GPL
Groups: rcss
Submitter: None
Maintainer: nslxndr
Last Packager: nslxndr
Votes: 1
Popularity: 0.000000
First Submitted: 2007-11-23 01:57
Last Updated: 2015-06-20 20:21

Dependencies (6)

Required by (3)

Sources (1)

Latest Comments

nslxndr commented on 2015-02-06 14:49

Fixed.

kiarash commented on 2015-02-06 12:20

It does not work with the new makepkg.
==> ERROR: arch contains invalid characters: ','

nslxndr commented on 2014-03-21 22:31

Works fine again, thank you!
We programming agents at the university and I have a little localisation bug patch to rcssmonitor, so if it's no longer current for you, I would like to maintain this package too of course.

nslxndr commented on 2014-03-21 22:31

Now works fine again, thank you!
We programming agents at the university and I have a little localisation bug patch to rcssmonitor, so if it's no longer current for you, I would like to maintain this package too of course.

masoud commented on 2014-03-20 21:26

I applied your suggestions.
I see that you maintain the rest of the rcss*. If you're interested I can disown this for you. Since I don't work on 2D soccer anymore.

nslxndr commented on 2014-03-20 09:02

Thanks for fast response. A few weeks earlier I made this package without problem too. Now md5sum is passed, but makepkg gives another error:
==> Validating source files with md5sums...
rcssmonitor-15.1.0.tar.gz ... Passed
==> Extracting sources...
-> Extracting rcssmonitor-15.1.0.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
/home/dealexos/packages/rcssmonitor/PKGBUILD: line 17: cd: /home/dealexos/packages/rcssmonitor/src/rcssmonitor-15.1.0/: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

I have a suggestion to solve this problem (I used this path in PKGBUILD of rcssserver and works fine):
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr
make
}

package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}

And if you allows me some additional tips based on output of namcap tool:
- Dependency qt4, boost-libs>=1.32 detected but not included.
- Dependency libice, libxpm, libx11 included but not needed.
make package is member of base-devel package group, so you don't need mark as dependency.

nslxndr commented on 2014-03-20 09:00

Thanks for fast response. A few weeks earlier I made this package without problem too. Now md5sum is passed, but makepkg gives another error:
==> Validating source files with md5sums...
rcssmonitor-15.1.0.tar.gz ... Passed
==> Extracting sources...
-> Extracting rcssmonitor-15.1.0.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
/home/dealexos/packages/rcssmonitor/PKGBUILD: line 17: cd: /home/dealexos/packages/rcssmonitor/src/rcssmonitor-15.1.0/: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

I have a suggestion to solve this problem (I used this path in PKGBUILD of rcssserver and works fine):
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr
make
}

package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}

And if you allows me some additional tips based on output of namcap tool:
- Dependency qt4, boost-libs>=1.32 detected but not included.
- Dependency libice, libxpm, libx11 included but not needed.
make package is member of base-devel package group, so don't need mark as dependency.

masoud commented on 2014-03-20 04:29

Thanks dealexos
I changed the md5sum to the new one. It should be fixed now.
Oddly enough, the old rcssmonitor-15.1.0.tar.gz I have has a different md5sum from the one on sourcefourge, but the file is marked as last modified in 2012 there.

nslxndr commented on 2014-03-19 20:13

Hi! I get md5sum error when I try to install:
==> Validating source files with md5sums...
rcssmonitor-15.1.0.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build rcssmonitor.