Package Details: reaper-bin 6.14-1

Git Clone URL: https://aur.archlinux.org/reaper-bin.git (read-only, click to copy)
Package Base: reaper-bin
Description: Digital Audio Workstation
Upstream URL: http://www.reaper.fm
Licenses: custom
Conflicts: reaper
Submitter: david0
Maintainer: david0
Last Packager: david0
Votes: 75
Popularity: 1.35
First Submitted: 2018-08-10 15:40
Last Updated: 2020-09-23 04:30

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

UlrichH commented on 2018-07-30 17:25

It won't generate a package, the new ln commands seem wrong

spider-mario commented on 2018-07-28 20:44

The executable is now called reaper instead of reaper5. Would it be possible to fix the /usr/bin/ symlink?

dtris commented on 2018-07-22 17:00

I tried running u-he's native Linux build of Zebra2 inside REAPER and it fails to load.

According to this thread, the solution to this is to make libSwell with PRELOAD_GDK defined (e.g. by running make PRELOAD_GDK=1. I tested that out and it seems to work and, AFAICT, it doesn't affect anything else.

Would you consider adding that to the PKGBUILD?

liberodark commented on 2018-07-19 17:11

REAPER 5.93 officialy on linux :D

Solace_Greyowl commented on 2018-06-21 04:00

pkgver doesnt equal 5.92rc2 on the landoleet website, thus making the newest release unable to install because it cant download . I don't know if I have the ability to make changes to the pkgbuild but the correct version should be 592.

spider-mario commented on 2018-05-08 19:27

No, it’s only an error because of -Werror which turns warnings into errors, and ALLOW_WARNINGS suppresses that flag: https://github.com/justinfrankel/WDL/blob/ed2812b54ea8990c23cf7dd6db3afa69487077f3/WDL/swell/Makefile#L28-L30

You can see it in the failing build log:

cc1plus: all warnings being treated as errors

donvla commented on 2018-05-07 19:24

But this option only suppresses the warning. The error - if it's one - still persists.

twisted-space commented on 2018-05-07 18:00

@ spider-mario, thanks that (make ALLOW_WARNINGS=yes) worked.

spider-mario commented on 2018-05-07 17:46

The problem is that the upstream Makefile sets -Wall -Werror unless ALLOW_WARNINGS is defined, and GCC 8, which just reached [core], introduces new warnings.

You can fix that by replacing make in the PKGBUILD with make ALLOW_WARNINGS=yes (or =whatever, all that matters is that it’s defined).

twisted-space commented on 2018-05-07 17:23

@funkmuscle yes, same error here.