Package Details: redact-bin 0.17.4-1

Git Clone URL: https://aur.archlinux.org/redact-bin.git (read-only, click to copy)
Package Base: redact-bin
Description: Customize Redact to remove the content you'd like. Remove old tweets, images, discord messages, and much more.
Upstream URL: https://redact.dev/
Licenses: custom
Conflicts: redact
Provides: redact
Submitter: Bjorkalx
Maintainer: johnpyp
Last Packager: johnpyp
Votes: 7
Popularity: 0.030399
First Submitted: 2021-06-29 03:52 (UTC)
Last Updated: 2023-11-12 08:49 (UTC)

Dependencies (0)

Required by (0)

Sources (2)

Latest Comments

johnpyp commented on 2023-11-12 08:55 (UTC)

Just updated, the build was originally compatible, but the asset was recently removed in favor of a newer version.

@proledatarian I can add you as a maintainer if you'd like.

proledatarian commented on 2023-08-28 17:57 (UTC) (edited on 2023-08-28 18:04 (UTC) by proledatarian)

The download link is not correct. Replace with the following:

source=("https://download.redact.dev/linux/Redact-${pkgver}.zip"

Okay, that also doesn't work apparently. If you don't want to maintain this package anymore, let me know. I would happily take over. Also your e-mail address is also not working anymore.

johnpyp commented on 2022-12-30 06:06 (UTC) (edited on 2022-12-30 06:07 (UTC) by johnpyp)

Note: this package is not actually out of date, redact 0.16.5 is the most recent binary. Redact follows a model similar to Discord where the primary binary isn't all of the assets, and doesn't need to be updated constantly. There are two versions in the app, one of which reflects the dynamically updated assets.

alyway commented on 2022-10-12 00:43 (UTC)

namcap produces these dependency errors

redact-bin E: Dependency alsa-lib detected and not included (libraries ['usr/lib/libasound.so.2'] needed in files ['opt/redact-bin/redact'])
redact-bin E: Dependency gtk3 detected and not included (libraries ['usr/lib/libgtk-3.so.0'] needed in files ['opt/redact-bin/redact'])
redact-bin E: Dependency at-spi2-core detected and not included (libraries ['usr/lib/libatspi.so.0', 'usr/lib/libatk-1.0.so.0', 'usr/lib/libatk-bridge-2.0.so.0'] needed in files ['opt/redact-bin/redact'])
redact-bin E: Dependency nss detected and not included (libraries ['usr/lib/libnss3.so', 'usr/lib/libnssutil3.so', 'usr/lib/libsmime3.so'] needed in files ['opt/redact-bin/redact'])

namcap -i says depends=(at-spi2-core gtk3 nss alsa-lib) should work