Package Details: redeclipse 1.6.0-1

Git Clone URL: https://aur.archlinux.org/redeclipse.git (read-only)
Package Base: redeclipse
Description: free, casual arena shooter
Upstream URL: http://redeclipse.net
Licenses: custom, CCPL:by-sa, zlib, CCPL:by
Submitter: mtorromeo
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 89
Popularity: 0.180936
First Submitted: 2011-03-15 22:28
Last Updated: 2018-01-04 08:50

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

carlwgeorge commented on 2015-04-06 01:57

I've actually been traveling, so I haven't had a chance to work on this much or help upstream. I did get a moment last night to bump the version to 1.5.1. I just submitted 1.5.1-2 that includes a patch of the commit you mentioned had the fix.

aexoxea commented on 2015-04-05 15:17

Thanks again for the update!

As part of checking my build locally, I had a quick look at the upstream commits to system-install.mk: https://github.com/red-eclipse/base/commits/master/src/system-install.mk .

The good news is that (2) has now been fixed by commit 0e67905 (and a huge 'thank you' for any involvement you had with that!). The bad news is that commit came after v1.5.1 was tagged.

As there have been several commits to system-install.mk since tagging, I patched using the latest revision available at this writing (commit 38ba0f8). That worked without any trouble, and I have updated the BBS thread to reflect this.

aexoxea commented on 2015-04-04 01:29

Many thanks for that. Sounds good about getting (2) fixed upstream; I'm very new to GitHub, but let me know if you need someone to vote for/support/whatever a patch.

Anyone who wants to build in the meantime has the workaround in the BBS thread.

carlwgeorge commented on 2015-04-03 19:09

Howdy @aexoxea. I noticed (1) also and had fixed it, I guess I accidentally uploaded 1.5.0-3 without the fix. Fixed in 1.5.0-4. As far as (2), I want to take a closer look and see if I can fix it properly in the Makefile and send a patch upstream.

aexoxea commented on 2015-04-03 05:18

Hi @carl.george, my thanks also for taking on the maintainership, and for the updates today :-)

I am still having two issues with the stock 1.5.0-3 PKGBUILD, though I might be alone on this:

(1) The system-install.mk script uses a mixture of 'sed' and 'ed' (why is unclear). 'ed' isn't part of base or base-devel (unlike 'sed'), so the script errored first time through; fixed locally by adding 'ed' as a makedepend.

(2) redeclipse errors at launch if the 'config' directory is not present. This directory is in base-1.5.0 at the same level as 'src', but is not installed by system-install.mk; fixed locally by copying the 'config' directory under /usr/share/redeclipse/config/ and symlinking to /usr/lib/redeclipse/config during the package() stage.

Finally, I also updated the BBS thread created before the maintainer change (so it no longer gives outdated information, and I don't want to be stepping on your toes!).

carlwgeorge commented on 2015-04-03 03:31

1.5.0-2 is still broken, but I found a fix upstream.

https://github.com/red-eclipse/base/commit/91e32211548fbf11a118c8961c609486ca0e6f31

I have ported this patch in 1.5.0-3. Based on other commits, it appears this fix will be included in the upstream 1.5.1, which is already in the source, just waiting to be tagged.

carlwgeorge commented on 2015-04-02 21:44

@Ulukai Thanks for the heads up, I hadn't gotten around to testing yet. Try to build 1.5.0-2 and see if that fixes it for you.

Ulukai commented on 2015-04-02 18:43

First of all thanks for picking this up again. However, I believe there is a problem with the installer. When upgrading my 1.4 installation, Red Eclipse got removed from the system and 1.5 is not installed in its place. There is no RE icon in my application list and no RE command to be found on the console either.

Please check the installer.

wookietreiber commented on 2015-03-31 09:09

Sorry for delay. When I adopted, I thought I had time to tackle it. Unfortunately, I have been busy with other stuff. Orphaning.

carlwgeorge commented on 2015-03-29 17:22

@wookietreiber If you're not going to update this package, please orphan it so someone else can.