Package Details: redeclipse 1.6.0-1

Git Clone URL: https://aur.archlinux.org/redeclipse.git (read-only)
Package Base: redeclipse
Description: free, casual arena shooter
Upstream URL: http://redeclipse.net
Licenses: custom, CCPL:by-sa, zlib, CCPL:by
Submitter: mtorromeo
Maintainer: None
Last Packager: FredBezies
Votes: 90
Popularity: 0.677237
First Submitted: 2011-03-15 22:28
Last Updated: 2018-01-04 08:50

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

aexoxea commented on 2015-03-29 09:10

Have removed my previous comments as I now have it working locally; see the following post for details: https://bbs.archlinux.org/viewtopic.php?pid=1515126 .

aexoxea commented on 2015-03-29 02:53

p.s. Just extracting the source package and running redeclipse.sh (from e.g. your home directory) works fine. Of course, that isn't a long-term solution...

aexoxea commented on 2015-03-28 13:54

Well, having had a small amount of time to kill, I tried (unsuccessfully) to create an updated version of this package.

Making just the obvious changes, I kept running into errors under system-install.mk in the package() step. I managed to stop these by:

- Adding 'ed' as a makedepend
- Updating the make install line to include variables APPCLIENT="redeclipse_linux" APPSERVER="redeclipse_server_linux"
- Patching system-install.mk to include the line "$(MKDIR) $(datadir)/$(appname)" as the first step under "system-install-data:"

This gets it packaging and installing OK, but when launching, it crashes immediately with the error "could not find config directory". There is nothing in the man page, upstream wiki or forums that immediately helps with this.

So, I admit failure for now. Hopefully, someone can work with the above (ideally, someone more familiar with how RE/Cube works under the hood than myself), or I can look at it again when more free time permits (no idea when that will be though!)

In the interests of not causing confusion, I am also happy to remove this comment if requested.

Anonymous comment on 2015-03-25 12:28

The new version is located at http://media1.gamefront.com/moddb/2015/03/22/redeclipse_1.5_nix.tar.bz2

FredBezies commented on 2015-03-22 14:14

Orphaning it. Feel free to adopt it and upgrade it.

FredBezies commented on 2015-03-22 11:03

I will upgrade it to version 1.5 as soon as it is available on mirrors.

FredBezies commented on 2014-05-28 10:09

redeclipse 1.4-3 : added .AURINFO file

dotfloat commented on 2014-02-12 13:02

namcap complains about glu being unneeded, but it's added now anyways.

Korsi commented on 2014-02-10 16:43

Please add glu as a dependency.

xordspar0 commented on 2013-11-24 11:27

xdg-utils still isn't listed as a dependency.