Package Details: redmine 3.3.3-0

Git Clone URL: https://aur.archlinux.org/redmine.git (read-only)
Package Base: redmine
Description: A flexible project management web application. Written using the Ruby on Rails, it is cross-platform and cross-database.
Upstream URL: http://www.redmine.org
Licenses: GPL2
Provides: redmine
Submitter: mawcomw
Maintainer: mawcomw
Last Packager: mawcomw
Votes: 59
Popularity: 0.017346
First Submitted: 2013-03-03 15:34
Last Updated: 2017-06-04 01:30

Dependencies (17)

Required by (0)

Sources (1)

Latest Comments

RubenKelevra commented on 2017-04-03 09:38

I like to point out that a simple downgrade from ruby to 2.3 is currently sufficient to get remine back to work. So if you would pin the ruby-version one would just need to ignore the update of ruby as long as there is no redmine-update.

RubenKelevra commented on 2017-03-29 06:20

Redmine 3.3.2 only supports ruby 2.3.

Please update the dependency accordingly.

See http://www.redmine.org/issues/25460

RubenKelevra commented on 2017-03-29 06:05

I've updated this package to the latest version, but the db:migrate does not go thru:

/usr/lib/ruby/gems/2.4.0/gems/htmlentities-4.3.1/lib/htmlentities/mappings/expanded.rb:465: warning: key "inodot" is duplicated and overwritten on line 466
/usr/lib/ruby/gems/2.4.0/gems/activesupport-4.2.7.1/lib/active_support/core_ext/numeric/conversions.rb:121: warning: constant ::Fixnum is deprecated
/usr/lib/ruby/gems/2.4.0/gems/activesupport-4.2.7.1/lib/active_support/core_ext/numeric/conversions.rb:121: warning: constant ::Bignum is deprecated
rake aborted!
SystemStackError: stack level too deep
/usr/share/webapps/redmine/config/environment.rb:14:in `<top (required)>'
/usr/bin/bundle:22:in `load'
/usr/bin/bundle:22:in `<main>'
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)

Tido.com commented on 2015-04-23 11:07

Until the package is updated you can modify the PKGBUILD with this one-liner:

echo -e "5,6c5,6\n< pkgver=3.0.0\n< pkgrel=1\n---\n> pkgver=3.0.1\n> pkgrel=0\n41c41\n< md5sums=('946d6c7173033f62ad98892bb0939dcf')\n---\n> md5sums=('bf63ceef4fde0d38d17d94969478d422')" | patch PKGBUILD

or if you prefer the diff:
5,6c5,6
< pkgver=3.0.0
< pkgrel=1
---
> pkgver=3.0.1
> pkgrel=0
41c41
< md5sums=('946d6c7173033f62ad98892bb0939dcf')
---
> md5sums=('bf63ceef4fde0d38d17d94969478d422')

Tido.com commented on 2015-02-03 22:30

Until the package is updated you can modify the PKGBUILD with this one-liner:

echo -e "5,6c5,6\n< pkgver=2.6.0\n< pkgrel=2\n---\n> pkgver=2.6.1\n> pkgrel=0\n41c41\n< md5sums=('bc0b9b8f078557c084719be429ef2067')\n---\n> md5sums=('dce687396b393ccaf26fdcd3465b7436')" | patch PKGBUILD

or if you prefer the diff:
5,6c5,6
< pkgver=2.6.0
< pkgrel=2
---
> pkgver=2.6.1
> pkgrel=0
41c41
< md5sums=('bc0b9b8f078557c084719be429ef2067')
---
> md5sums=('dce687396b393ccaf26fdcd3465b7436')

ryanmjacobs commented on 2015-01-20 07:09

@mawcomw Can you please update this for v2.6.1? Thanks.

Cybo commented on 2014-04-21 07:02

pkgbuild diff for 2.5.1: https://gist.github.com/anonymous/11134530

mawcomw commented on 2014-01-10 00:57

@RubenKelevra: i retested it all again and didn't get any error.

It could be incompatibilities with some plugins you are using, or maybe you forgot to run the "bundle update", and a outdated gem isn't updated...

It seems to be something with an outdated gem or a plugin... Could you send me your gem list and plugins list (with versions)?

Thanks for your report.

RubenKelevra commented on 2014-01-09 13:07

After update from 2.4.1 to 2.4.2 running "rake generate_secret_token" will fail:

[root@x redmine]# rake generate_secret_token
rake aborted!
undefined method `enforce_available_locales=' for I18n:Module

[root@x redmine]# cat config/application.rb | grep enforce_available_locales
I18n.enforce_available_locales = false

Removing this line will fix the problem, so it would be nice if you can fix it. :)

RubenKelevra commented on 2013-11-21 15:16

2.3.4 and 2.4 is out

All comments