Package Details: rednotebook 2.3-2

Git Clone URL: https://aur.archlinux.org/rednotebook.git (read-only)
Package Base: rednotebook
Description: A simple desktop diary.
Upstream URL: http://rednotebook.sourceforge.net
Keywords: diary notes personal
Licenses: GPL2
Submitter: FadeMind
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 32
Popularity: 1.719814
First Submitted: 2015-08-12 04:14
Last Updated: 2018-01-15 09:51

Latest Comments

SanskritFritz commented on 2018-01-15 09:52

Thanks tedbuckland.

tedbuckland commented on 2018-01-14 10:27

It seems that the dependency "python-gobject" is missing (here and in the rednotebook-git package). This should also fix the problem in the last comment.

NKataDelYoda commented on 2017-12-06 19:22

I received the following error on installation:

Traceback (most recent call last): File "/usr/bin/rednotebook", line 6, in <module> import journal ModuleNotFoundError: No module named 'journal'</module>

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File "/usr/bin/rednotebook", line 11, in <module> import rednotebook.journal File "/usr/lib/python3.6/site-packages/rednotebook/journal.py", line 43, in <module> gi.require_version("Gtk", "3.0") AttributeError: module 'gi' has no attribute 'require_version'</module></module>

I did a "pip install journal", and now the module is found, but now I get the error "AttributeError: module 'journal' has no attribute 'main'".

Is this an issue with the journal module, or perhaps the Python version installed on my system? I'm running a straight Arch installation.

SanskritFritz commented on 2017-10-13 08:01

You're right, thank you for the heads-up!

MaoCPU commented on 2017-10-12 22:00

rednotebook-2.3 seems to work with the PKGBUILD at https://gist.github.com/anonymous/e7de431b90a3c178d7bee68848ee146c

I replaced the dependency on python-webkit with webkit2gtk and added the optional dependency to PyEnchant (according to rednotebook dependency information).

haawda commented on 2017-05-20 07:14

Orphaning.

Munto commented on 2016-12-03 03:47

Ola !
I get this error when I try to launch the soft:
2016-12-03 04:39:05,347 ERROR pywebkitgtk not found. Please install it (python-webkit): No module named webkit

I think a dependency is missing.

Thanks for the package!

Anonymous comment on 2016-11-15 21:44

You are right.

haawda commented on 2016-11-14 21:25

Why did you have to install python2-jswebkit, if pywebkitgtk was not found?

I added python2-yaml and pywebkitgtk as dependencies.

Anonymous comment on 2016-11-14 11:18

I got this error:

2016-11-14 12:17:48,093 ERROR PyYAML not found. Please install it (python-yaml).

So I had to install community/python2-yaml
Then I got this error:

2016-11-14 12:18:45,699 ERROR pywebkitgtk not found. Please install it (python-webkit): No module named webkit

So I had to install community/python2-jswebkit

haawda commented on 2016-10-09 20:39

Someone marked this out of date, because of a warning about pygtkspellcheck missing. But with python2-gtkspellcheck installed, rednotebook does not even start.

emvigo commented on 2016-05-28 14:55

@graysky: Thanks for the comments. I've removed the .install file; I'll leave the return statements because IMHO they add clarity to what the possible outcomes might be.

graysky commented on 2016-05-28 14:23

You can remove the .install file as pacman hooks do this automatically; also the `|| return 1` statements aren't needed. Thank you for maintaining.