Package Details: redshift-gtk-git 1.11.r132.g91e1d30-1

Git Clone URL: https://aur.archlinux.org/redshift-git.git (read-only, click to copy)
Package Base: redshift-git
Description: Adjusts the color temperature of your screen according to your surroundings (development version)
Upstream URL: http://jonls.dk/redshift/
Licenses: GPL3
Submitter: ShyPixie
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 49
Popularity: 0.011129
First Submitted: 2013-11-13 12:17 (UTC)
Last Updated: 2017-12-28 22:29 (UTC)

Latest Comments

Gotit commented on 2021-11-08 22:25 (UTC)

Having trouble building/installing, I believe the dependencies need to be updated as I get:

could not satisfy dependencies: - unable to satisfy dependency 'redshift-git=1.11.r132.g91e1d30' required by redshift-gtk-git

redshift-git is now at: redshift-git=1.11.r132.g91e1d30-1

skjnldsv commented on 2021-03-28 10:29 (UTC)

It recently stopped building properly. tthe gtk package does NOT contain the gtk binaries anymore

hrvoj3e commented on 2019-01-06 20:11 (UTC)

There is a newer version (1.12: from May 21, 2018) in community repo: https://www.archlinux.org/packages/community/x86_64/redshift/

carstene1ns commented on 2018-12-18 14:18 (UTC)

@viperpaulo: It is already listed as dependency?

viperpaulo commented on 2018-12-16 16:37 (UTC) (edited on 2018-12-18 05:22 (UTC) by viperpaulo)

Needs python-gobject to run gtk tray icon, maybe as optional depends it's enough ;)

bluhue commented on 2014-10-06 12:04 (UTC)

Running yaourt -Syua --devel wants to upgrade: Targets (2): redshift-git redshift-gtk-git. However, when proceeding with the upgrade: ==> Starting pkgver()... ==> Updated version: redshift-git 1.9.1.r34.g44782ec-1 ==> Sources are ready. ==> WARNING: This PKGBUILD describes a splitted package. ==> Specific package options are unknown ==> redshift-git is already up to date. and ==> Starting pkgver()... ==> Updated version: redshift-git 1.9.1.r34.g44782ec-1 ==> Sources are ready. ==> WARNING: This PKGBUILD describes a splitted package. ==> Specific package options are unknown ==> redshift-git is already up to date.

carstene1ns commented on 2014-09-30 18:12 (UTC)

@hugoroy: This can likely be ignored, it just means you are not using a compatible environment (gnome3/unity/...) for ubuntu's app indicators [1]. redshift-gtk should fallback to a normal tray icon. [1]: https://unity.ubuntu.com/projects/appindicators/

hugoroy commented on 2014-09-30 16:49 (UTC)

I get this: ERROR:root:Could not find any typelib for AppIndicator3

carstene1ns commented on 2014-07-07 10:16 (UTC)

@fx101: Why do you flag this package out-of-date when it is not? If it is broken, please say so in the comments. Flag removed.

carstene1ns commented on 2014-06-05 22:09 (UTC)

Seems like it is needed after the last commit, so added as makedep. Thank you, @Brottweiler!

Brottweiler commented on 2014-06-05 11:39 (UTC)

Please add intltool as dependency. Without it building fails.

carstene1ns commented on 2014-06-03 05:18 (UTC)

FYI: With the new AUR release, this is now a split package.

carstene1ns commented on 2014-03-04 21:36 (UTC)

Adopted this package and changed the dependencies to python3 for redshift-gtk.

saturn_knight commented on 2014-01-13 03:58 (UTC)

Now supports Python3. Changes I had to make for a successful installation: * Change python2-xdg to python-xdg in optdepends * Change python2 to python in makedepends * Add python-gobject to optdepends for redshift-gtk (gtk-redshift is renamed) * Remove the sed command from the prepare block as it is no longer necessary. * Remove the PYTHON env variable from the configure command in the buld block.

ShyPixie commented on 2013-12-09 11:50 (UTC)

Thank you! Updated

Barthalion commented on 2013-12-08 12:10 (UTC)

Well, these fixes can be applied to your PKGBUILD as well. * there is no git in makedepends * instead of weird magic in pkgver() you can just run: git describe --tags | sed 's/^v//;s/-/./g' * makepkg always starts in $srcdir, so there is no need to include it in cd paths

ShyPixie commented on 2013-12-07 21:15 (UTC)

@Barthalion package already updated, no need bluephones47's PKGBUILD

Barthalion commented on 2013-12-07 18:49 (UTC)

I did some amendments to bluephones47's PKGBUILD: https://paste.xinu.at/B1u/

aksr commented on 2013-05-28 05:24 (UTC)

bluephoenix47: Thank you. It'll be applied. ;)

wilbowma commented on 2013-05-27 23:45 (UTC)

FWIW, I wrote this PKGBUILD using new makepkg support: http://sprunge.us/ZRSi. I was actually going to write a redshift-bzr package, before I realized it already existed.