Package Details: redshift-wlr-gamma-control-git 1.12.r25.geecbfed-1

Git Clone URL: https://aur.archlinux.org/redshift-wlr-gamma-control-git.git (read-only)
Package Base: redshift-wlr-gamma-control-git
Description: Adjusts the color temperature of your screen according to your surroundings with Wayland wlr-gamma-control protocol support. (development version)
Upstream URL: https://github.com/minus7/redshift/tree/wayland
Licenses: GPL3
Conflicts: redshift
Provides: redshift
Submitter: eggze
Maintainer: eggze
Last Packager: eggze
Votes: 8
Popularity: 1.401392
First Submitted: 2018-08-19 13:32
Last Updated: 2019-04-21 17:06

Dependencies (12)

Required by (14)

Sources (1)

Latest Comments

eggze commented on 2019-04-21 17:19

Thanks for the info @minus, the version is adjusted now.

minus commented on 2019-04-20 09:37

I squashed a lot of commits, thus the version number that gets generated is lower than the one given in the PKGBUILD, thus yay rebuilds it every time I upgrade. Could you adjust the version please? The current version is 1.12.r25.geecbfed

eggze commented on 2019-02-10 09:47

@jakebailey Sorry for the delay, wayland is now added to makedepends.

@evernow It seems to me that you need to use manual method or install geoclue2 properly. I think I had this issue with a regular redshift as well, that's why I have location-provider=manual in my config file, check the man page please.

jakebailey commented on 2019-02-07 00:01

Pinging about the wayland makedep. (It'd nice to be able to build this for my aurutils repo.)

@evernow Are you using sway-git? This package assumes you're using it (since I don't think wlr-gamma-control is implemented by anything else). It's been working for me for a while.

evernow commented on 2019-01-19 22:05

This does not work for me.

Getting "Failed to run Redshift

Trying location provider 'geoclue2'... Cannot connect to wayland display, exiting. Failed to start adjustment method wayland. Trying next method... Waiting for initial location to become available... Unable to start GeoClue client: GDBus.Error:org.freedesktop.DBus.Error.NoReply:Message recipient disconnected from message bus without replying. Unable to get location from provider

jakebailey commented on 2019-01-04 18:00

Forgive the quick followup, but I realized after posting that I should test it under X to see if it works without wayland as well, and it does. A makedep is probably the right way to go given this package just adds the wayland support without affecting any other functionality. I tested the package with wayland as a makedep with i3, and it works as expected.

jakebailey commented on 2019-01-04 17:53

Wonderful, thank you. One more thing I've found now that I can build it; this depends on the wayland package to build as well. I'm not sure if it should be a makedep or a regular dependency, though. Most likely a regular dependency given you need wayland at runtime to actually use this.

Adding wayland to depends lets the package build, and I confirmed that it works with sway-git.

eggze commented on 2019-01-01 12:56

@jakebailey added

jakebailey commented on 2018-12-31 17:27

Can git be added as a makedep? Right now, this can't be built in a clean chroot (e.g. with aurutils).