Package Details: restic 0.8.1-1

Git Clone URL: https://aur.archlinux.org/restic.git (read-only)
Package Base: restic
Description: restic is a program that does backups right.
Upstream URL: https://restic.github.io
Licenses: BSD
Submitter: ImNtReal
Maintainer: ImNtReal (fd0)
Last Packager: fd0
Votes: 25
Popularity: 4.212049
First Submitted: 2016-09-06 20:32
Last Updated: 2017-12-28 08:02

Latest Comments

MazeChaZer commented on 2018-01-08 16:40

@ImNtReal thanks for the tip, works great.

ImNtReal commented on 2018-01-08 16:00

@MazeChaZer, try adding export makeopts="-A" to your profile. It might save you headaches with other packages, and won't leave me adding a multitude of different ARM architectures to the arch array.

MazeChaZer commented on 2018-01-07 13:21

I use restic on my Raspberry Pi, which has the processor architecture "armv6h". It compiles without problems, but during the install I have to add "armv6h" to the list of supported architectures in the PKGBUILD. I couldn't really find a policy about this, do you think it would be possible to add "armv6h" to the arch variable in the PKGBUILD?

Also, the upstream URL seems to be https://restic.net/ now.

willemw commented on 2017-11-19 12:44

"conflicts=('restic-git')" is redundant:
restic-git already has "conflicts=('restic')"

egrupled commented on 2017-10-22 21:41

Please change 'go>=1.7' to 'go' as it creates conflicts when "go-pie" is installed (anyway versioned deps doesn't make sense in arch). Even better change it to 'go-pie' which arch migrates to https://www.archlinux.org/todo/go-pie-rebuild/

fd0 commented on 2017-05-29 20:38

FYI: I'm the author of restic and I'm available for co-maintainership, if you like :)

Since restic 0.5.0, it requires Go >= 1.7: https://github.com/restic/restic/releases/tag/v0.5.0

jesrui commented on 2017-02-14 10:23

Please update dependencies. restic depends on go>=1.6.