Package Details: restview 3.0.1-1

Git Clone URL: https://aur.archlinux.org/restview.git (read-only, click to copy)
Package Base: restview
Description: A viewer for ReStructuredText documents that renders them on the fly
Upstream URL: https://mg.pov.lt/restview/
Licenses: GPL
Submitter: giniu
Maintainer: SpotlightKid
Last Packager: SpotlightKid
Votes: 14
Popularity: 0.000001
First Submitted: 2010-03-25 15:48 (UTC)
Last Updated: 2023-05-11 23:45 (UTC)

Latest Comments

SpotlightKid commented on 2016-08-23 21:25 (UTC)

I've uploaded a new package 'python-readme-renderer' and filed a request for merging 'python-readme' into it.

IooNag commented on 2016-08-23 14:16 (UTC)

Hi, the new version of restview does not work on my system: it crashes with error "pkg_resources.DistributionNotFound: The 'readme_renderer' distribution was not found and is required by restview". This is because the readme package got renamed readme_renderer in its last version (cf. a warning in https://pypi.python.org/pypi/readme/0.7.1). Downgrading to restview 2.4.0-1 fixes this issue.

giniu commented on 2015-03-31 10:24 (UTC)

@SpotlightKid: updated using your PKGBUILD. Thanks.

giniu commented on 2015-03-18 14:40 (UTC)

thanks, I will check it out

SpotlightKid commented on 2015-03-18 13:24 (UTC)

I've created an updated PKGBUILD with the following changes: * Update version to 2.3.0 * Build for Python 3 * Replace python-distribute make dependency with python-setuptools * Add python-readme (AUR) dependency * Make python-pygments dependency non-optional It's available here: http://trac.chrisarndt.de/code/browser/projects/aur/restview/

SpotlightKid commented on 2014-09-15 10:01 (UTC)

Version 2.1.0 is out with a useful fix for the --long-description option. Just updating the version and md5sum in the PKGBUILD works.

giniu commented on 2012-04-05 10:34 (UTC)

No problem, glad it's useful.

msx commented on 2012-04-02 03:19 (UTC)

Tnx for AURing this.