Package Details: rhc 1.38.4-2

Git Clone URL: (read-only)
Package Base: rhc
Description: The client tools for the OpenShift platform that allow for application management.
Upstream URL:
Licenses: Apache
Submitter: OmeGa
Maintainer: OmeGa
Last Packager: OmeGa
Votes: 35
Popularity: 0.170079
First Submitted: 2013-03-27 05:57
Last Updated: 2016-03-30 21:03

Latest Comments

bluetech commented on 2016-09-23 10:54

The dependency ruby-net-ssh-multi does not exist.

iskenderoguz commented on 2016-08-01 22:40

version 1.38.7 :

OmeGa commented on 2016-03-30 21:06

@Marcel_K: Using ruby-net-ssh-2.9.2 as a dependency now. Thanks.

Marcel_K commented on 2016-03-26 02:39

@talueses: The dependencies *are* okay, just don't blindly follow yaourt, please learn how to build packages yourself (using the wiki I linked to).

And please report outdated dependencies at their pages, not here.

talueses commented on 2016-03-26 02:28

I like report that one of the dependencies is outdated:

ruby-net-ssh-multi 1.2.1-1 (2015-06-14 02:21)
This package is orphaned

talueses commented on 2016-03-26 02:06

@Marcel_K i quoting this comments because it seems relevant still not resolved as such dependencies without errors.
But, thanks so much for your help, bro. :)

Marcel_K commented on 2016-03-26 01:07

Even simpler: I just made package ruby-net-ssh-2.9.2 so you can clone and install that one.

@OmeGa: please replace the dependency of ruby-net-ssh with ruby-net-ssh-2.9.2 and everything will be fine for the yaourt builders (at least I hope so).

Marcel_K commented on 2016-03-26 00:50

@iskenderoquz: That's a message from yaourt, isn't it? Just don't use that helper, but build ruby-net-ssh yourself, see, i.e.:

- clone the Git repository of ruby-net-ssh
- go back to version 2.9.2 by issuing

git checkout f3b7d73

- run makepkg
- install the package with pacman -U <package>

Then do the same with this package.

Marcel_K commented on 2016-03-26 00:44

@talueses: Why are you quoting old (obsolete) comments? ruby-commander-4.2.1 and ruby-highline-1.6 are already dependencies. This packages downloads (current) version 1.38.4 and the checksum is correct. According to the official page at, rhc depends on net-ssh <= 2.9.2, so this dependency is also correct. The unsupported package message is a default message of yaourt (IIRC), you should always be cautious when downloading packages from the AUR and inspect PKGBUILDs and other provided files.

BTW, why is this package flagged out-of-date? It isn't.

iskenderoguz commented on 2016-03-26 00:38

I get this error

==> Continue building rhc ? [Y/n]
==> -----------------------------
==> Building and installing package
==> Install or build missing dependencies for rhc:
error: target not found: ruby-net-ssh<2.9.3
==> Restart building rhc ? [y/N]
==> ----------------------------

All comments