Package Details: rhythmbox-git 3.3.1.r3.gc414b79-1

Git Clone URL: (read-only)
Package Base: rhythmbox-git
Description: Music playback and management application
Upstream URL:
Keywords: gnome music player podcast
Licenses: GPL2
Conflicts: rhythmbox
Provides: rhythmbox=3.3.1.r3.gc414b79
Submitter: hussam
Maintainer: archdria
Last Packager: archdria
Votes: 25
Popularity: 0.000019
First Submitted: 2009-04-29 01:56
Last Updated: 2016-04-11 06:58

Dependencies (34)

Required by (13)

Sources (1)

Latest Comments

dantob commented on 2016-01-06 02:20

please add to the prepare section to fix build with core build tools

'git revert --no-edit 85c185d5dc662945f98860ea6092b2f9927dac8f'

removes commit 'audioscrobbler: build a separate static library for tests'

Chazza commented on 2014-06-01 21:24

There's no need to flag it out of date. This is a git package so it will fetch the latest git sources. The PKGBUILD has a pkgver() function which means that the version number/string will automatically be updated to the correct version before the build begins.

cracoucass14 commented on 2014-04-04 08:17

version is now 3.0.2

luolimao commented on 2013-05-19 16:24

Never mind, just tested it out and the old gstreamer isn't needed.

luolimao commented on 2013-05-16 20:48

I've changed the last two, but what about gstreamer0.10-python? It still depends on the old version of gstreamer.

easyonthev commented on 2013-05-14 17:17

There's a few dependency changes that can be made:

gstreamer instead of gstreamer0.10
libsecret instead of python2-gnomekeyring
libmusicbrainz3 can be dropped

and python 3 is now being used instead of python 2


luolimao commented on 2013-01-14 23:42

Yeah, the package is out-of-date (cuurent = 3.6.0, new = 3.7.4). I've flagged it out of date.

luolimao commented on 2013-01-14 23:36

It's lines 347-357 in /usr/bin/ that are the culprit:

luolimao commented on 2013-01-14 23:32

Yeah, I traced it to the gnome-common package, which only checks up to automake 1.12 atm. Sorry, nothing I can do.

altkrall commented on 2013-01-05 23:33

automake 13.1 is too new for rhythmbox-git.

checking for automake >= 1.7...
testing automake-1.12... not found.
testing automake-1.11... not found.
testing automake-1.10... not found.
testing automake-1.9... not found.
testing automake-1.8... not found.
testing automake-1.7... not found.
***Error***: You must have automake >= 1.7 installed
to build rhythmbox. Download the appropriate package for
from your distribution or get the source tarball at

luolimao commented on 2012-11-30 22:14


archdria commented on 2012-11-29 17:56

I got this error when building:
Checking for required M4 macros...
yelp.m4 not found
***Error***: some autoconf macros required to build rhythmbox
were not found in your aclocal path, or some forbidden
macros were found. Perhaps you need to adjust your

So I had to install yelp-tools as a makedep :)

luolimao commented on 2012-11-06 03:16

Fixed, thanks.

Anonymous comment on 2012-11-06 00:02

In the PKGBUILD it looks for python-gnomekeyring, this package is now named python2-gnomekeyring. Can we get an edit to the PKGBUILD so that it doesn't manually need to be entered?

luolimao commented on 2012-10-09 23:58


Anonymous comment on 2012-06-16 23:29

I'm sorry, but I'm unable to compile it there's a problem in the build

Thx for any response or update

td123 commented on 2011-08-28 22:33

hmm, wait a bit and try again later, I successfully rebuilt this package earlier today.
I suspect they are doing something on the backend which is causing you to fail.

LeCrayonVert commented on 2011-08-28 20:17

Works for but not git:// . I dunno why...

LeCrayonVert commented on 2011-08-28 20:15

td123 > thx for this update. I've got a connection timed out with can't clone the git repo from the command line either...

td123 commented on 2011-08-08 14:45

updated package because the one in [extra] is noticeably buggy.

rebased it on the rhythmbox PKGBUILD, so everything should be packaged well

hussam commented on 2011-05-03 15:11

Disowned. After 5 years of using Gnome, I had to switch to something else.

vorbote commented on 2011-03-19 13:19

To compile GNOME 3's rhythmbox, edit the PKGBUILD file and replace 'xulrunner=>1.9' with 'libwebkit3=>1.3'. (That is, you don't need xulrunner installed unles you are using Firefox, Thunderbird or something else that has a hard dependency on xulrunner.)