Package Details: rime-ice-git r478.a33bd8d-1

Git Clone URL: https://aur.archlinux.org/rime-ice-git.git (read-only, click to copy)
Package Base: rime-ice-git
Description: Rime 配置:雾凇拼音 | 长期维护的简体词库
Upstream URL: https://github.com/iDvel/rime-ice
Keywords: rime
Licenses: GPL-3.0-or-later
Conflicts: rime-ice-double-pinyin, rime-ice-double-pinyin-abc, rime-ice-double-pinyin-flypy, rime-ice-double-pinyin-mspy, rime-ice-double-pinyin-sogou, rime-ice-double-pinyin-ziguang, rime-ice-pinyin
Provides: rime-ice
Submitter: everyx
Maintainer: everyx (lilac)
Last Packager: lilac
Votes: 8
Popularity: 0.63
First Submitted: 2023-01-08 08:09 (UTC)
Last Updated: 2024-03-17 04:22 (UTC)

Dependencies (5)

Required by (0)

Sources (1)

Pinned Comments

everyx commented on 2023-04-11 01:34 (UTC) (edited on 2024-03-17 02:32 (UTC) by everyx)

本包包含「雾凇拼音」提供的所有方案,如果只需要使用其中一种,请选择安装:

目前已将方案默认的 default.yaml 作为 rime_ice_suggestion.yaml 包含,如需使用方案的默认配置,可以使用「补丁」的方式应用:

在用户目录下的 default.custom.yaml 文件中

patch:
  # 仅使用「雾凇拼音」的默认配置,配置此行即可
  __include: rime_ice_suggestion:/
  # 以下可根据自己所需进行自定义,仅做参考。

针对特定方案的定制项目,请在 [方案].custom.yaml 中配置,例如:启用 is_in_user_dict ,编辑 rime_ice.custom.yaml 并配置如下:

patch:
  engine/filters/+:
    - lua_filter@is_in_user_dict

分包后安装时会打包所有包而导致的时间过长的问题

由于 makepkg 在 5.0 后移除了支持单独构建拆分包中单个包的选项(来源),所以所有的 AUR helper 应该都不支持编译单个包。如果觉得安装的时候打包时间太长,此包已提交至 Arch Linux CN 社区仓库,建议启用 Arch Linux CN 源。

Latest Comments

1 2 3 Next › Last »

AllenWu233 commented on 2024-03-12 14:02 (UTC) (edited on 2024-03-12 14:02 (UTC) by AllenWu233)

安装时报错

感谢大佬的耐心指导!原来是我不小心把/usr/share/rime-date删掉了,重装rime-prelude后就能正常安装了

everyx commented on 2024-03-11 13:19 (UTC)

安装时报错:

@AllenWu233 我刚刚测试了一下,编译没有问题呢?能否提供一下你出错的 PKGBUILD 文件,发到我邮箱 lunt.luo#gmail.com

AllenWu233 commented on 2024-03-11 09:08 (UTC)

安装时报错:

==> 正在进入 fakeroot 环境...
==> 正在开始 package_rime-ice-git()...
install: 对 './build/melt_eng.*.bin' 调用 stat 失败: 没有那个文件或目录
install: 对 './build/melt_eng.*.yaml' 调用 stat 失败: 没有那个文件或目录
==> 错误: 在 package_rime-ice-git() 中发生一个错误。
    正在放弃...
 -> 生成时出错: rime-ice-git-exit status 4
 -> 无法安装以下软件包, 需要手动介入处理:
rime-ice-git - exit status 4

everyx commented on 2024-03-07 03:22 (UTC) (edited on 2024-03-08 01:03 (UTC) by everyx)

重构之后似乎又要把所有的方案都编译一遍才能装其中的一个了?是我用的不对吗

@zilch40 我也发现了这个现象,不知道是不是所有 AUR helper 对于拆分报的默认行为都是这样,我抽空研究看看

EDIT: makepkg 在 5.0 后移除了支持单独构建拆分包中单个包的选项(来源),所以所有的 AUR helper 应该都不支持编译单个包。我在用 CN 源的话,也许应该将这个包申请加入到 CN 源,这样直接安装打包好的包,就省了本地的编译过程了,我抽空看看怎么提交

zilch40 commented on 2024-03-06 15:31 (UTC)

重构之后似乎又要把所有的方案都编译一遍才能装其中的一个了?是我用的不对吗

everyx commented on 2024-03-06 13:34 (UTC)

麻烦添加一下t9和double_pinyin_sougou的schema到_default.yaml里面,否则的话会报错

@1997cui 已修复,忘了注释掉 _default.yaml 中未支持的方案了(目前为 T9),并加入了搜狗和紫光双拼方案。

1997cui commented on 2024-03-06 06:52 (UTC) (edited on 2024-03-06 06:53 (UTC) by 1997cui)

麻烦添加一下t9和double_pinyin_sougou的schema到_default.yaml里面,否则的话会报错:

Mar 05 22:45:44 fcitx5[14652]: E20240305 22:45:44.703346 132985267422912 deployment_tasks.cc:210] missing input schema: double_pinyin_sogou Mar 05 22:47:26 fcitx5[14652]: E20240305 22:47:26.514721 132985267422912 deployment_tasks.cc:210] missing input schema: t9

everyx commented on 2024-03-03 03:16 (UTC)

在 这个 PR 之后,中英混输词库的拓展名由 yaml 变为 txt,导致中英混输词库未被打包,请修复。

@su226 重构了一下,已修复。

su226 commented on 2024-02-19 08:12 (UTC) (edited on 2024-02-19 08:12 (UTC) by su226)

这个 PR 之后,中英混输词库的拓展名由 yaml 变为 txt,导致中英混输词库未被打包,请修复。

everyx commented on 2023-06-19 00:55 (UTC)

请将新的 double_pinyin_abc 加入 _schemas

@szsdk 已更新