Package Details: ring-gnome 1:1.0.0.r58.g4ce8a2b-1

Git Clone URL: https://aur.archlinux.org/ring-gnome.git (read-only)
Package Base: ring-gnome
Description: The GNOME client for ring.cx (formerly known as SFLphone)
Upstream URL: http://ring.cx
Keywords: audio chat gnome opendht P2P ring video
Licenses: GPL3
Groups: ring
Submitter: zorun
Maintainer: zorun
Last Packager: zorun
Votes: 23
Popularity: 5.164802
First Submitted: 2016-02-17 19:48
Last Updated: 2016-08-28 09:09

Latest Comments

deemde commented on 2016-08-24 14:49

Yes. Not sure why this did fail.
libringclient did build today. Thanks for checking in.

ArchangeGabriel commented on 2016-08-23 12:15

Did you properly rebuilt opendht, ring-daemon and libringclient in that order before rebuilding ring-gnome?

deemde commented on 2016-08-23 12:06

I get a compilation error:
»class AccountModel« has no member named »slotConnectivityChanged«
AccountModel::instance().slotConnectivityChanged();
Bad commit base?

rrt commented on 2016-04-19 15:33

I still get this error on calling "Origin and destination states are identical" https://tuleap.ring.cx/plugins/tracker/?aid=579&group_id=101. Thank you for the info zorun!

caevaroy commented on 2016-04-12 22:24

Solved it by using the 'whoneeds' utility to get remove all apps from my system that were depending on protobuf3. Then installed protobuf. Then installed ring-gnome. Then reinstalled all my other apps.

zorun commented on 2016-04-11 18:00

Ah, I see, you are using protobuf3 from the AUR, not the protobuf version from the official repositories (2.6.1 at the moment): https://www.archlinux.org/packages/extra/x86_64/protobuf/ . So, protobuf3 might or might not work with Ring, but there's nothing I can do. Besides, protobuf is a dependency of libphonenumber, which is itself a dependency of evolution-data-server, so it's not directly related to Ring.

caevaroy commented on 2016-04-10 18:10

zorun: I have /usr/lib/libprotobuf.so.10 on my system. It seems ring-gnome is requiring an older version. protobuf3 provides protobuf

zorun commented on 2016-04-09 10:04

caevaroy, for the cmake error, you obviously need an up-to-date system. For the protobuf error, I think it's also because your system is not up-to-date, since protobuf is a dependency of libphonenumber.

rrt, yes, sending and receiving calls is supposed to work. The logs from the daemon should be more interesting, they are in journalctl (try e.g. "journalctl -b -t dring").

caevaroy commented on 2016-04-08 23:37

/usr/bin/ld: warning: libprotobuf.so.9, needed by /usr/lib/libphonenumber.so.7, not found

caevaroy commented on 2016-04-06 19:55

failed retrieving file 'cmake-3.5.0-1-x86_64.pkg.tar.xz' from ... : The requested URL returned error: 404

All comments