Package Details: ringcentral-bin 22.1.31.2868-3

Git Clone URL: https://aur.archlinux.org/ringcentral-bin.git (read-only, click to copy)
Package Base: ringcentral-bin
Description: Video Conferencing and Web Conferencing Service.
Upstream URL: https://www.ringcentral.com
Licenses: MIT
Submitter: KenwoodFox
Maintainer: KenwoodFox
Last Packager: KenwoodFox
Votes: 2
Popularity: 0.000005
First Submitted: 2022-01-03 22:21 (UTC)
Last Updated: 2023-03-15 23:14 (UTC)

Dependencies (55)

Required by (0)

Sources (1)

Pinned Comments

fattminer commented on 2022-03-23 16:38 (UTC)

@hedin504 I found that launching it with the --no-sandbox parameter made it work. Strange issue though

Latest Comments

parandr commented on 2023-03-12 19:24 (UTC)

The source link: https://rcm.ringcentral.com/client/latest/ringcentral_amd64.deb returns 404 error when trying to install.

lectrode commented on 2022-10-29 20:17 (UTC)

For future reference, debtap is a good starting point for new packages, but should be polished before uploading, as it is not perfect and can pull in more than what is actually required.

pactree (provided by pacman-contrib) provides an easy way to see what packages are already dependencies of another dependency. For example, fontconfig and a bunch of other packages were already pulled in by gtk3 and its dependencies, no reason to explicitly state all of those when you already explicitly depend on gtk3.

lectrode commented on 2022-10-29 20:03 (UTC)

Some more dependency cleanup. Removed dependencies that are either always installed (required by base) or required (directly or indirectly) by other dependencies:

depends=('gtk3' 'ibus' 'qt5-3d' 'qt5-gamepad' 'qt5-multimedia' 'qt5-quickcontrols2' 'qt5-remoteobjects' 'qt5-script' 'qt5-svg' 'qt5-wayland' 'qt5-webengine' 'qt5-xmlpatterns')

anaconda alone pulls in nearly 5GB, and (like cuda) is primarily focused on machine learning. I don't know what ringcentral would need that for, and neither of those are dependencies of the original deb package. At most it should be an optional dependency.

KenwoodFox commented on 2022-10-19 14:51 (UTC)

Good point @lectrode, let me test and remove that, I'm not sure exactly why cuda-tools was added as a dep.

lectrode commented on 2022-10-19 07:32 (UTC)

Any idea why this package relies on cuda-tools (and subsequently cuda)? That dependency alone requires over 7GB installed, and this app seems to work fine after running sudo pacman -Rdd cuda cuda-tools

Maybe it should be an optional dependency?

KenwoodFox commented on 2022-03-28 03:12 (UTC)

So strange @fattminer

fattminer commented on 2022-03-23 16:38 (UTC)

@hedin504 I found that launching it with the --no-sandbox parameter made it work. Strange issue though

hedin504 commented on 2022-03-20 13:23 (UTC)

Can not login to my account. The login page is blank with an endless spinner on it.