Package Details: ripmime r13.a556ffe-2

Git Clone URL: https://aur.archlinux.org/ripmime.git (read-only)
Package Base: ripmime
Description: Tool to extract the attached files out of a MIME package
Upstream URL: https://github.com/inflex/ripMIME
Licenses: BSD
Submitter: ahphaw5S
Maintainer: ahphaw5S
Last Packager: ahphaw5S
Votes: 2
Popularity: 0.000004
First Submitted: 2015-11-05 07:54
Last Updated: 2018-05-22 09:22

Dependencies (1)

Required by (1)

Sources (1)

Latest Comments

stef204 commented on 2018-05-22 10:55

works in clean chroot now. thank you.

ahphaw5S commented on 2018-05-22 09:24

hmm, that's odd. I tried to fix it. Let me know if it doesn't work again...

stef204 commented on 2018-05-22 08:59

@ahphaw5S Fails to build on my up-to-date system, including in clean chroot. ==> ERROR: Cannot find the git package needed to handle git sources. ==> ERROR: An unknown error has occurred. Exiting...

If I edit line 10 as such: source=('https://github.com/inflex/ripMIME') it goes on to d/l the source but hangsup again on pkgver which probably needs fixing.

==> Starting pkgver()... ==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace. ==> ERROR: pkgver() generated an invalid version: /startdir/PKGBUILD: line 17: cd: /build/ripmime/src/ripMIME: No such file or directory

ahphaw5S commented on 2018-05-22 07:40

I switched the source to a git repository, where it seems issues with newer gcc have been solved.

intelfx commented on 2018-05-22 04:34

gcc6 has been dropped to AUR and from now on this package makes people build gcc6 from source. Please do something about it.

Rhinoceros commented on 2018-05-11 06:54

The url appears to have changed. Everything works if I remove the www. at the beginning of both urls.

ahphaw5S commented on 2018-01-13 19:41

Thanks, @meck, I must have missed the message from @Afwas.

The build errors you are referring to seems to be a gcc7 bug (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80924).

I have added gcc6 as a temporary make dependency.

meck commented on 2018-01-13 13:50

with the gcc 7 compiler, the installation does not work anymore (some problems with make....)

my solution was to install the gcc6 compiler

sudo pamcan -S gcc6

and change two things in the PKGBUILD file

1: as AFWAS suggested to leaf out the bracklets arround url=http://www.pldaniels.com/ripmime/

2: I inserted the line

export CC=/usr/bin/gcc-6

below the line "package() {"

then the installation worked

Afwas commented on 2016-03-18 15:23

The url line should not be an array. Please leave the brackets out and this package installs fine. Thanks.
url=http://www.pldaniels.com/ripmime/