Package Details: riscv-openocd 20170818.23-1

Git Clone URL: https://aur.archlinux.org/riscv-openocd.git (read-only)
Package Base: riscv-openocd
Description: Fork of OpenOCD that has RISC-V support
Upstream URL: https://github.com/riscv/riscv-openocd
Keywords: risc-v
Licenses: GPL
Submitter: esmil
Maintainer: esmil
Last Packager: esmil
Votes: 2
Popularity: 0.009458
First Submitted: 2017-09-09 13:18
Last Updated: 2017-09-09 13:18

Required by (0)

Sources (1)

Latest Comments

imi415 commented on 2019-02-16 05:45

Hi esmil,
This PKGBUILD is designed to update its version at each prepare step, which is set by git tags in pkgver().
But your pkgver variable provided to AUR is not the same style as git tags do.
So when quering from AUR, helpers will consider this version is way far ahead and try to 'upgrade' this package.
Edit: This seems due to a tagging style change from upstream.

esmil commented on 2019-02-08 09:16

Hi banzr,

The version of this package has never been anything but 20170818.23-1. I don't know where you got 2018.12.0.181-1 from, sorry.

banzr commented on 2019-02-08 01:08

Was the version number updated? I installed this package a week ago and the version was 2018.12.0.181-1. Now the version is 20170818.23-1. I recommend either changing your 'pkgver' variable to <= 2018.XXXX.... so that system updates don't needlessly mark this package as out of date. Pacman compares version numbers and 20170818 > (2018 or 2019) so it thinks the package is out of date even though its not.

For more guidance, see: https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver()_function