Package Details: rivalctl-git r27.0bbf7c3-2

Git Clone URL: https://aur.archlinux.org/rivalctl-git.git (read-only)
Package Base: rivalctl-git
Description: SteelSeries Rival configuration tool
Upstream URL: https://github.com/nixi-awoo/rivalctl
Licenses: GPL3
Conflicts: rivalctl
Provides: rivalctl
Submitter: nixi
Maintainer: nixi
Last Packager: nixi
Votes: 2
Popularity: 0.000000
First Submitted: 2015-04-06 11:01
Last Updated: 2016-04-08 23:09

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

sbt1 commented on 2016-06-06 07:25

did you try to sudo it or use it as root? that solved it for me.

nixi commented on 2016-06-04 12:51

@d1x
That is not a problem with the package, but with the program itself.
Please create a new issue at the github repository (Upstrem URL) and we can discuss it there.
Make sure to add the model number of your mouse.

d1x commented on 2016-06-03 01:22

Hi, installation went OK but setting anything fails (e.g. rivalctl --cpi1 400) on:

Traceback (most recent call last):
File "/usr/bin/rivalctl", line 9, in <module>
load_entry_point('rivalctl==0.1', 'console_scripts', 'rivalctl')()
File "/usr/lib/python3.5/site-packages/rival/rivalctl.py", line 66, in main
_main(args)
File "/usr/lib/python3.5/site-packages/rival/rivalctl.py", line 19, in _main
device = open_device()
File "/usr/lib/python3.5/site-packages/rival/rival.py", line 64, in open_device
device = Rival(dev_path = dev_path)
File "/usr/lib/python3.5/site-packages/rival/rival.py", line 82, in __init__
device = open_hiddevice(hid_id, dev_path)
File "/usr/lib/python3.5/site-packages/rival/rival.py", line 41, in open_hiddevice
device = hidraw.HIDRaw(open(dev_path, 'w+'))
TypeError: invalid file: None

any idea what's wrong?

sbt1 commented on 2015-08-30 21:29

ok, installable without problems, works perfect.

thank you very, very much!

sbt1 commented on 2015-08-30 21:28

works like a charm, thank you very much for the quick fix!

Anonymous comment on 2015-08-30 18:26

@sbt1 python2-webcolors now in the aur. You should have no issue with that now.

sbt1 commented on 2015-08-30 18:03

Hi,

the package "python2-webcolors" does not exist, I can only find the "python" (so python3, I guess) version. Is there any way I overlooked to get it?

And I can not build the dependency "python-hidraw-git" because of a problem with its dependency "python-ioctl-opt-git", the comment is there:

https://aur.archlinux.org/packages/python-hidraw-git/

I would love to use this application, and hope to get it working!

Thank you very much!