Package Details: river 0.1.3-3

Git Clone URL: https://aur.archlinux.org/river.git (read-only, click to copy)
Package Base: river
Description: A dynamic tiling wayland compositor.
Upstream URL: https://github.com/riverwm/river
Licenses: GPL3
Conflicts: river-bin, river-git, river-noxwayland-git
Provides: river, riverctl, rivertile
Submitter: andreafeletto
Maintainer: andreafeletto
Last Packager: andreafeletto
Votes: 16
Popularity: 1.26
First Submitted: 2021-11-03 08:58 (UTC)
Last Updated: 2022-05-09 21:05 (UTC)

Latest Comments

andreafeletto commented on 2022-03-27 11:22 (UTC)

Just updated, thanks for the heads up. I added the version requirement when river required zig 0.9.0 but it wasn't yet packaged in the arch repos. I will probably have to add it back for the next release. This is a problem with zig not being (yet) backwards compatible (so zig>=0.9.0 won't work), so adding and removing the version requirement is the only thing I can do.

kugelblitz commented on 2022-03-27 11:07 (UTC)

Right now, the PKGBUILD requires zig=0.9.0 which means that the regular zig won't work anymore as it's been updated to 0.9.1. Ironically, the git version still works because the AUR version number has not been updated so it still says 0.9.0 despite being a newer build.

There is no reason why the PKGBUILD cant allow for zig>=0.9.0. Forcing 0.9.0 only forces everyone to use the git version of zig which only adds an additional point of failiure. Also, it means that this repo is one version bump away from breaking.

TL;DR please change zig=0.9.0 to zig>=0.9.0

sheercold commented on 2022-01-05 17:30 (UTC)

You can install this version of wlroots from Arch's Community-Staging repository

https://archlinux.org/packages/community-staging/x86_64/wlroots/

then update river with this AUR.

t3hyoshi commented on 2021-12-24 06:29 (UTC) (edited on 2021-12-24 06:30 (UTC) by t3hyoshi)

For those who say there's no wlroots >=0.15 available, use wlroots-git. The top comment there says the package will always fetch the latest source tree.

JohnTheCF commented on 2021-12-24 04:40 (UTC)

This package depends on wlroots >= 0.15.0 but such wlroots version is not available in AUR or official repos.

zerathidune commented on 2021-11-04 04:24 (UTC)

This is missing a build dependency on zig.

wbthomason commented on 2021-11-03 20:16 (UTC)

It seems that the checksums for this package may be out of date - river-0.1.0.tar.gz fails the validity check.