Package Details: rivercarro-git r17.4f714a5-1

Git Clone URL: https://aur.archlinux.org/rivercarro-git.git (read-only, click to copy)
Package Base: rivercarro-git
Description: A slightly modified version of rivertile layout generator for river.
Upstream URL: https://git.sr.ht/~novakane/rivercarro
Keywords: manager river tiling window wlroots
Licenses: GPL3
Conflicts: rivercarro
Provides: rivercarro
Submitter: ronin
Maintainer: ronin
Last Packager: ronin
Votes: 2
Popularity: 0.000214
First Submitted: 2021-07-22 06:58 (UTC)
Last Updated: 2021-12-22 01:15 (UTC)

Dependencies (2)

Required by (0)

Sources (1)

Pinned Comments

ronin commented on 2021-12-22 04:54 (UTC)

Seems arch has now shipped zig version 0.9.0. this package however depends on version 0.8.0 so river and this package will be broken for a while. My advice is manually install zig 0.8.0 and wlroots 0.14.0. :D

Latest Comments

sheercold commented on 2023-09-25 23:37 (UTC) (edited on 2023-10-17 00:37 (UTC) by sheercold)

Got this error

zig: error while loading shared libraries: libclang-cpp.so.15: cannot open shared object file: No such file or directory ==> ERROR: A failure occurred in package(). Aborting... error: failed to build 'rivercarro-git-r17.4f714a5-1':

Edit: The error had been resolved with rivercarro update to zig 0.11

ronin commented on 2021-12-25 05:56 (UTC)

commit https://github.com/riverwm/river/tree/9c2e3b6738097dd38abea69a59c700c1ec0bc53f has now fixed bumped zig version 0.9.0. do comment if this still builds with zig 0.9.0

ronin commented on 2021-12-22 04:54 (UTC)

Seems arch has now shipped zig version 0.9.0. this package however depends on version 0.8.0 so river and this package will be broken for a while. My advice is manually install zig 0.8.0 and wlroots 0.14.0. :D

dedguy21 commented on 2021-10-06 23:48 (UTC)

I'm getting a error. A failed to clone 'deps/zug-wayland' a second time, aborting

What's the work around?

ronin commented on 2021-07-23 14:19 (UTC)

fixed pkgbuild. thanks for pointing that out.