Package Details: rkward 0.7.0b-4

Git Clone URL: https://aur.archlinux.org/rkward.git (read-only, click to copy)
Package Base: rkward
Description: An easy to use and easily extensible IDE/GUI for R
Upstream URL: https://rkward.kde.org/
Licenses: GPL
Conflicts: rkward, rkward-git
Provides: rkward
Submitter: seal20
Maintainer: palasso
Last Packager: palasso
Votes: 7
Popularity: 0.044357
First Submitted: 2015-09-24 02:57
Last Updated: 2019-11-22 09:55

Latest Comments

palasso commented on 2019-11-22 09:56

Package updated with backported patch to fix build errors.

will1942 commented on 2019-11-22 00:04

Hey you. The package is not compiling in my laptop.

Erros

/home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp: In constructor ‘RKWorkplace::RKWorkplace(QWidget)’: /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:71:2: error: ‘QVBoxLayout’ was not declared in this scope; did you mean ‘QLayout’? 71 | QVBoxLayout message_layout = new QVBoxLayout (message_area); | ^~~~~~~~~~~ | QLayout /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:71:15: error: ‘message_layout’ was not declared in this scope; did you mean ‘message_area’? 71 | QVBoxLayout message_layout = new QVBoxLayout (message_area); | ^~~~~~~~~~~~~~ | message_area /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:71:36: error: expected type-specifier before ‘QVBoxLayout’ 71 | QVBoxLayout message_layout = new QVBoxLayout (message_area); | ^~~~~~~~~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:74:15: error: ‘vbox’ was not declared in this scope 74 | QVBoxLayout vbox = new QVBoxLayout (this); | ^~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:74:26: error: expected type-specifier before ‘QVBoxLayout’ 74 | QVBoxLayout vbox = new QVBoxLayout (this); | ^~~~~~~~~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:84:2: error: ‘QHBoxLayout’ was not declared in this scope; did you mean ‘QLayout’? 84 | QHBoxLayout hbox = new QHBoxLayout (harea); | ^~~~~~~~~~~ | QLayout /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:84:15: error: ‘hbox’ was not declared in this scope 84 | QHBoxLayout hbox = new QHBoxLayout (harea); | ^~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:84:26: error: expected type-specifier before ‘QHBoxLayout’ 84 | QHBoxLayout hbox = new QHBoxLayout (harea); | ^~~~~~~~~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp: In member function ‘void RKWorkplace::addMessageWidget(KMessageWidget)’: /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:131:25: error: invalid use of incomplete type ‘class QLayout’ 131 | message_area->layout ()->addWidget (message); | ^~ In file included from /usr/include/qt/QtWidgets/qtabwidget.h:44, from /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.h:23, from /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:18: /usr/include/qt/QtWidgets/qwidget.h:65:7: note: forward declaration of ‘class QLayout’ 65 | class QLayout; | ^~~~~~~ /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp: In member function ‘RKMDIWindow RKWorkplace::openOutputWindow(const QUrl&)’: /home/$USER/.cache/yay/rkward/src/rkward-0.7.0b/rkward/windows/rkworkplace.cpp:486:57: warning: unused parameter ‘url’ [-Wunused-parameter] 486 | RKMDIWindow RKWorkplace::openOutputWindow (const QUrl &url) { | ~~~~~~~~~~~~^~~ make[2]: [rkward/windows/CMakeFiles/windows.dir/build.make:180: rkward/windows/CMakeFiles/windows.dir/rkworkplace.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:1924: rkward/windows/CMakeFiles/windows.dir/all] Error 2 make: *** [Makefile:141: all] Error 2 ==> ERRO: Uma falha ocorreu em build(). Abortando... Error making: rkward

JonnyRobbie commented on 2018-09-09 11:51

Update to suntax-highlighting causes

error: failed to commit transaction (conflicting files) rkward-frameworks-git: /usr/share/org.kde.syntax-highlighting/syntax/r.xml exists in filesystem (owned by syntax-highlighting).

I suggest removing the offending files after build.

naraesk commented on 2018-05-17 11:18

Will you update the package to 0.7 which is based on kf5?

Nicky726 commented on 2017-02-12 10:29

Needs libkdewebkit.so.5 from kdelibs=4.14.28-1, which is no longer present in the 4.14.29-1 version currently in repos. With the current kdelibs it does not run, nor does it compile. So far, reverting the kdelibs seems to be a feasible workaround.