Package Details: ros-indigo-qt-gui-cpp 0.2.32-1

Git Clone URL: https://aur.archlinux.org/ros-indigo-qt-gui-cpp.git (read-only)
Package Base: ros-indigo-qt-gui-cpp
Description: ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
Upstream URL: http://ros.org/wiki/qt_gui_cpp
Licenses: BSD
Submitter: bchretien
Maintainer: yuxiang.li
Last Packager: yuxiang.li
Votes: 1
Popularity: 0.000000
First Submitted: 2014-06-07 16:37
Last Updated: 2017-02-25 21:43

Latest Comments

emersonjr commented on 2016-11-14 18:15

You should have qt5-base installed before installing this package.

In my environment, i was facing the following issue.

Getting fatal error: QWidget: No such file or directory
#include <QWidget>

In order to solve it, i did:
vim /yourpath/packages/qt_gui_core-release-release-indigo-qt_gui_cpp-0.2.30-0/src/qt_gui_core-release-release-indigo-qt_gui_cpp-0.2.30-0/src/qt_gui_cpp_sip/../../include/qt_gui_cpp/plugin_context.h

then change:

#include <QWidget>

by:

#include <QtGui>

Then you will probably face an issue about the version of qmake that is running.

`which qmake` will show you which qmake is in your path.

You have to make sure you are using qmake for qt4.
So the last change, was:

`sudo mv /usr/bin/qmake /usr/bin/qmake.bk`
`sudo ln -s /usr/bin/qmake-qt4 /usr/bin/qmake`
( Make sure to revert those changes later if you want to. )


Everything should be fine after all. :D

Alad commented on 2016-04-24 04:15

Doesn't build:

https://ptpb.pw/xqNT