Package Details: ros-kinetic-collada-urdf 1.12.12-1

Git Clone URL: https://aur.archlinux.org/ros-kinetic-collada-urdf.git (read-only)
Package Base: ros-kinetic-collada-urdf
Description: ROS - This package contains a tool to convert Unified Robot Description Format (URDF) documents into COLLAborative Design Activity (COLLADA) documents.
Upstream URL: http://ros.org/wiki/collada_urdf
Licenses: BSD
Submitter: zootboy
Maintainer: jerry73204
Last Packager: jerry73204
Votes: 1
Popularity: 0.000492
First Submitted: 2016-12-21 06:17
Last Updated: 2018-11-05 00:16

Latest Comments

SMOG commented on 2019-01-17 12:50

I can't seem to be able to compile. I get the following error:

-- The C compiler identification is GNU 8.2.1
-- The CXX compiler identification is GNU 8.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Using CATKIN_DEVEL_PREFIX: /home/xxxx/.cache/yay/ros-kinetic-collada-urdf/src/build/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/kinetic
-- This workspace overlays: /opt/ros/kinetic
-- Found PythonInterp: /usr/bin/python2 (found version "2.7.15") 
-- Using PYTHON_EXECUTABLE: /usr/bin/python2
-- Using default Python package layout
-- Found PY_em: /usr/lib/python2.7/site-packages/em.pyc  
-- Using empy: /usr/lib/python2.7/site-packages/em.pyc
-- Using CATKIN_ENABLE_TESTING: ON
-- Skip enable_testing() when building binary package
-- Using CATKIN_TEST_RESULTS_DIR: /home/xxxx/.cache/yay/ros-kinetic-collada-urdf/src/build/test_results
-- Found gtest: gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.7.11
CMake Error at /opt/ros/kinetic/share/rosconsole/cmake/rosconsoleConfig.cmake:148 (message):
  Project 'collada_urdf' tried to find library '-lpthread'.  The library is
  neither a target nor built/installed properly.  Did you compile project
  'rosconsole'? Did you find_package() it before the subdirectory containing
  its code is included?
Call Stack (most recent call first):
  /opt/ros/kinetic/share/roscpp/cmake/roscppConfig.cmake:172 (find_package)
  /opt/ros/kinetic/share/collada_parser/cmake/collada_parserConfig.cmake:172 (find_package)
  /opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package)
  CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/xxxx/.cache/yay/ros-kinetic-collada-urdf/src/build/CMakeFiles/CMakeOutput.log".
See also "/home/xxxx/.cache/yay/ros-kinetic-collada-urdf/src/build/CMakeFiles/CMakeError.log".

Seems related to the CMakeLists, but I can't seem to get hot to fix it...