Package Details: ros-kinetic-gazebo-ros-pkgs 2.5.14-2

Git Clone URL: https://aur.archlinux.org/ros-kinetic-gazebo-ros-pkgs.git (read-only)
Package Base: ros-kinetic-gazebo-ros-pkgs
Description: ROS - Interface for using ROS with the Gazebo simulator.
Upstream URL: http://gazebosim.org/tutorials?cat=connect_ros
Licenses: BSD,LGPL,Apache 2.0
Submitter: zootboy
Maintainer: None
Last Packager: zootboy
Votes: 1
Popularity: 0.000000
First Submitted: 2017-02-13 21:35
Last Updated: 2018-03-27 05:19

Latest Comments

dpluy commented on 2018-03-27 15:07

I build it successfully just now as I export five environment variables: ROS_PACKAGE_PATH= ROS_MASTER_URI= ROS_ETC_DIR= ROS_ROOT= ROS_DISTRO=. Because I "source /opt/ros/kinetic/setup.zsh" in my .zshrc before I build this package. I guess that some conflicts about those PATH resulted previous errors like "XXXX/gazebo_plugins/xxx.hh: no such file..."or "missing math library", etc. ps: how to enter newline.

zootboy commented on 2018-03-27 05:21

I just did a bunch of patching to all the kinetic gazebo packages due to the removal of deprecated functions in gazebo 9. Kinetic officially targets 7, but it seems like relatively minor renamings. Give it a try and let me know if you have any problems.

dpluy commented on 2018-03-27 02:43

Are there anyone build it successfully? I also encountered some odd problems along with gazebo9.

zootboy commented on 2017-02-15 03:46

I would suggest rebuilding your full dependency tree, especially gazebo itself. This is something that almost none of the AUR helpers get right, and can lead to odd problems like this.

ct2034 commented on 2017-02-14 07:34

I get

/usr/include/gazebo-7/gazebo/msgs/altimeter.pb.h:17:2: error: #error This file was generated by an older version of protoc which is
#error This file was generated by an older version of protoc which is
^~~~~
/usr/include/gazebo-7/gazebo/msgs/altimeter.pb.h:18:2: error: #error incompatible with your Protocol Buffer headers. Please
#error incompatible with your Protocol Buffer headers. Please
^~~~~
/usr/include/gazebo-7/gazebo/msgs/altimeter.pb.h:19:2: error: #error regenerate this file with a newer version of protoc.
#error regenerate this file with a newer version of protoc.
^~~~~

How can I fix it?