Package Details: ros-lunar-cv-bridge 1.12.7-2

Git Clone URL: https://aur.archlinux.org/ros-lunar-cv-bridge.git (read-only)
Package Base: ros-lunar-cv-bridge
Description: ROS - This contains CvBridge, which converts between ROS Image messages and OpenCV images.
Upstream URL: http://www.ros.org/wiki/cv_bridge
Licenses: BSD
Submitter: racko
Maintainer: racko
Last Packager: racko
Votes: 1
Popularity: 0.000008
First Submitted: 2017-05-22 18:02
Last Updated: 2018-02-15 21:25

Latest Comments

racko commented on 2018-02-15 21:18

Thanks for your report. For now I have created an issue upsteam: https://github.com/ros-perception/vision_opencv/issues/202

Alad commented on 2018-02-10 18:01

I get the following error on build:

==> Starting build()...                                                                                                                            [217/5367]
-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is GNU 7.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Using CATKIN_DEVEL_PREFIX: /home/archie/.cache/aurutils/snapshot/ros-lunar-cv-bridge/src/build/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/lunar
-- This workspace overlays: /opt/ros/lunar
-- Found PythonInterp: /usr/bin/python2 (found version "2.7.14")
-- Using PYTHON_EXECUTABLE: /usr/bin/python2
-- Using default Python package layout
-- Found PY_em: /usr/lib/python2.7/site-packages/em.pyc
-- Using empy: /usr/lib/python2.7/site-packages/em.pyc
-- Using CATKIN_ENABLE_TESTING: OFF
-- catkin 0.7.8
-- Found PythonLibs: /usr/lib/libpython2.7.so (found version "2.7.14")
-- Boost version: 1.66.0
-- Found the following Boost libraries:
--   python
-- Found OpenCV: /usr (found suitable version "3.4.0", minimum required is "3") found components:  opencv_core opencv_imgproc opencv_imgcodecs
-- Found PythonLibs: /usr/lib/libpython2.7.so (found suitable version "2.7.14", minimum required is "2.7")
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named numpy
CMake Error at src/CMakeLists.txt:25 (message):
  Could not determine the NumPy include directory, verify that NumPy was
  installed correctly.


-- Configuring incomplete, errors occurred!
See also "/home/archie/.cache/aurutils/snapshot/ros-lunar-cv-bridge/src/build/CMakeFiles/CMakeOutput.log".

CMakeOutput.log

midgard commented on 2017-08-13 15:38

@racko That'd be great! Thanks.

racko commented on 2017-08-13 14:21

Hmm ... thx ... I used https://github.com/bchretien/arch-ros-stacks to create the ros-lunar packages. Guess I will have to fix that.

midgard commented on 2017-08-13 12:42

Hi, in PKGBUILD you should quote variables that may contain spaces, in particular ${srcdir} on lines 42, 52 (twice), 53, 56 and 59.

racko commented on 2017-08-07 14:04

TODO: ros-lunar-cv-bridge needs to depend on hdf5.

While opencv depends optionally on hdf5, doing "find_package(catkin REQUIRED COMPONENTS cv_bridge)" etc. will make your project link against /usr/lib/libopencv_hdf.so.* without any way to opt out.

EDIT: What a coincedence ... just yesterday https://github.com/ros-perception/vision_opencv/commit/8b5bbcbc1ce65734dc600695487909e0c67c1033 was merged. We only need to wait until this ends up in a release.