Package Details: ros-lunar-opencv3 3.3.1-1

Git Clone URL: https://aur.archlinux.org/ros-lunar-opencv3.git (read-only)
Package Base: ros-lunar-opencv3
Description: ROS - OpenCV 3.x.
Upstream URL: https://github.com/ros-gbp/opencv3-release
Licenses: BSD
Submitter: racko
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 0
Popularity: 0.000000
First Submitted: 2017-05-22 18:33
Last Updated: 2018-03-11 11:42

Latest Comments

tommy0705c commented on 2018-04-29 16:42

Due to Cuda9's feature ,if used gcc higher than 5 would occur:

nvcc warning : The 'compute_20', 'sm_20', and 'sm_21' architectures are deprecated, and may be removed in a future release (Use -Wno-deprecated-gpu-targets to suppress warning). In file included from /opt/cuda/include/cuda_runtime.h:78:0, from <command-line>:0: /opt/cuda/include/host_config.h:119:2: error: #error -- unsupported GNU version! gcc versions later than 5 are not supported! #error -- unsupported GNU version! gcc versions later than 5 are not supported! ^~~~~ CMake Error at cuda_compile_generated_gpu_mat.cu.o.cmake:206 (message): Error generating /tmp/yaourt-tmp-tommycc/aur-ros-lunar-opencv3/src/build/modules/core/CMakeFiles/cuda_compile.dir/src/cuda/./cuda_compile_generated_gpu_mat.cu.o</command-line>

racko commented on 2017-10-10 17:23

Do you use this package? I only pushed it by accident. The ros packages that need opencv where simply modified to use extra/opencv instead.

Would you mind if I remove it?

nitrotm commented on 2017-10-10 08:56

This package depends on libwebp-dev which is not available on AUR. It's packaged on official 'extra' channel as 'libwebp'.

Also there is a patch to apply to OpenCVCompilerOptions.cmake:

https://gist.github.com/nitrotm/b164822e467d60aef97cfecfbad91a26