Package Details: ros-lunar-ros-core 1.3.1-1

Git Clone URL: (read-only, click to copy)
Package Base: ros-lunar-ros-core
Description: ROS - A metapackage to aggregate the packages required to use publish / subscribe, services, launch files, and other core ROS concepts.
Upstream URL:
Licenses: BSD
Submitter: racko
Maintainer: racko
Last Packager: racko
Votes: 1
Popularity: 0.000000
First Submitted: 2017-05-22 17:33
Last Updated: 2017-05-22 17:33

Latest Comments

racko commented on 2017-09-30 16:07

In short: You always need to rebuild AUR packages when a core/extra/community dependency is updated like this. It's not an issue specific to the ros packages. I don't know if any AUR maintainers bump the package versions to force users to rebuild. It could be somewhat annoying because in the time between the dependency update and the AUR release bump, users might already have rebuild manually, forcing them to rebuild a second time, unnecessarily.

The boost version is not specified. Rebuilding the package will just link against the new version.

keeyan commented on 2017-09-30 15:07


I seem to be having some difficulty with this package. Whenever I run roscore I get the following error:


* /rosdistro: lunar
* /rosversion: 1.13.2


auto-starting new master
process[master]: started with pid [12675]

setting /run_id to ad2244e0-a5ef-11e7-8974-605718a32ea6
process[rosout-1]: started with pid [12688]
started core service [/rosout]
/opt/ros/lunar/lib/rosout/rosout: error while loading shared libraries: cannot open shared object file: No such file or directory
[rosout-1] process has died [pid 12688, exit code 127, cmd /opt/ros/lunar/lib/rosout/rosout __name:=rosout __log:=/home/keeyan/.ros/log/ad2244e0-a5ef-11e7-8974-605718a32ea6/rosout-1.log].
log file: /home/keeyan/.ros/log/ad2244e0-a5ef-11e7-8974-605718a32ea6/rosout-1*.log
[rosout-1] restarting process

It seems like roscore depends on ``, however I have ``(the latest version). When I manually downgrade to 1.64 roscore works fine. As Arch is a rolling release distro it is a bad idea to have out of date packages. I am not familiar with how AUR package releases work but if it is possible it would be great if you could change the dependency required to 1.65.1 instead of 1.74.