Package Details: ros-melodic-octomap 1.9.0-3

Git Clone URL: https://aur.archlinux.org/ros-melodic-octomap.git (read-only)
Package Base: ros-melodic-octomap
Description: ROS - The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++.
Upstream URL: http://octomap.github.io
Licenses: BSD
Submitter: GPereira
Maintainer: bionade24
Last Packager: GPereira
Votes: 0
Popularity: 0.000000
First Submitted: 2018-05-13 18:33
Last Updated: 2018-09-06 19:36

Latest Comments

GPereira commented on 2018-09-06 19:36

Thank you, edit made ;)

timonegk commented on 2018-09-06 10:41

options=('staticlibs') should be added to the PKGBUILD to keep the static library liboctomath.a which is needed by ros-melodic-octovis, ros-melodic-geometric-shapes and ros-melodic-dynamic-edt-3d.

tsp commented on 2018-08-13 02:01

This is what I get when I attempt to build the ros-melodic-octovis package:

-- octovis building as Release
CMake Error at /opt/ros/melodic/share/octomap/octomap-targets.cmake:94 (message):
  The imported target "octomath-static" references the file

     "/opt/ros/melodic/lib/liboctomath.a"

  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained

     "/opt/ros/melodic/share/octomap/octomap-targets.cmake"

  but not all the files it references.

Call Stack (most recent call first):
  /opt/ros/melodic/share/octomap/octomap-config.cmake:66 (include)
  CMakeLists.txt:45 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/troy/.cache/yay/ros-melodic-octovis/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
    Aborting...
Error making: ros-melodic-octovis

So we can see that /opt/ros/melodic/lib/liboctomath.a is missing however this (ros-melodic-octomap) also requires linking on that same archive, but it gets it from somewhere else. I'm thinking either the PKGBUILD for ros-melodic-octovis needs to be updated to pull it from the web as well or ros-melodic-octomap should install the copy of liboctomath.a it links against to /opt/ros/melodic/lib/liboctomath.a

GPereira commented on 2018-08-12 23:30

Hello! Thanks for the feedback! However I am not understanding your point. ros-melodic-octovis has this package as a make dependency. Are you saying that octovis also need that package to be linked?

tsp commented on 2018-08-11 10:01

This package links on liboctoamth.a that is included in the release by the looks of it. ros-melodic-octovis fails to build because that same lib isn't available at build time. I've also had issues attempting to build some of my own packages in a catkin workspace with it complaining that something was expecting /opt/ros/melodic/usr/lib/liboctomath.a to be available but it isn't there. I'm not sure what package is actually the issue - but I think maybe this needs to install that file/ we need another package to install those required deps to the ros melodic libs. What are your thoughts on this?