Package Details: ros-melodic-rosout 1.12.14-1

Git Clone URL: https://aur.archlinux.org/ros-melodic-rosout.git (read-only)
Package Base: ros-melodic-rosout
Description: ROS - System-wide logging mechanism for messages sent to the /rosout topic.
Upstream URL: http://ros.org/wiki/rosout
Licenses: BSD
Submitter: GPereira
Maintainer: bionade24
Last Packager: bionade24
Votes: 2
Popularity: 0.003920
First Submitted: 2018-02-24 12:24
Last Updated: 2019-05-11 17:01

Pinned Comments

bionade24 commented on 2019-02-14 17:05

Please execute git reset --hard HEAD~1 for fixing this.

Latest Comments

costashatz commented on 2019-03-04 01:31

Please change sha256sums and _dir:

_dir="ros_comm-release-release-melodic-rosout-${pkgver}-${_pkgver_patch}"

sha256sums=('3699399910840cdbd100ffa9f27e0ef478f516c1d3409c7f62d6af8e3ca59cc6')

jwhendy commented on 2019-02-17 20:49

sha256sums and should be _dir="ros_comm-release-release-melodic-rosout

bionade24 commented on 2019-02-14 17:05

Please execute git reset --hard HEAD~1 for fixing this.

MichaelChou commented on 2019-02-13 13:57

sha256sum changed

tsp commented on 2018-06-29 02:22

Came here to say that I just tried that and it worked :)

GPereira commented on 2018-06-28 08:56

Try removing all ROS packages and install them again since some packages may have compiled with the older version of boost and this one now wants 1.67

tsp commented on 2018-06-27 23:38

Still have the same problem here. What are some things I can try to fix it locally? Will I need to modify the source or is it likely just PKGBUILD configuration?

GPereira commented on 2018-06-27 15:14

Problem seems to be solved, check it now please

GPereira commented on 2018-06-27 06:46

Yes, things have changed a bit. Still searching for a solution... Please tell me if you find a way

tsp commented on 2018-06-26 11:03

Package fails to link with: /usr/bin/ld: warning: libboost_system.so.1.66.0, needed by /opt/ros/melodic/lib/librosconsole.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libboost_regex.so.1.66.0, needed by /opt/ros/melodic/lib/librosconsole.so, not found (try using -rpath or -rpath-link)

Boost updated recently to 1.67 in the official libs so it is probably to do with that. Shouldn't these packages be linking on 1.67 now or did the API change?