Package Details: ros2-git r249.3490c0f-1

Git Clone URL: https://aur.archlinux.org/ros2-git.git (read-only, click to copy)
Package Base: ros2-git
Description: A set of software libraries and tools for building robot applications (Rolling Distro)
Upstream URL: https://docs.ros.org/en/rolling/
Licenses: Apache
Provides: ros2
Submitter: m2-farzan
Maintainer: m2-farzan
Last Packager: AchmadFathoni
Votes: 1
Popularity: 0.000142
First Submitted: 2021-04-07 13:51 (UTC)
Last Updated: 2023-08-10 07:53 (UTC)

Dependencies (4)

Required by (0)

Sources (1)

Pinned Comments

m2-farzan commented on 2021-04-07 13:58 (UTC)

For feedback or contribution, either comment here or head to this GitHub page: https://github.com/m2-farzan/ros2-rolling-PKGBUILD

Latest Comments

MarsSeed commented on 2023-08-07 18:22 (UTC)

Although the necessary python-pyqt5 depends is already a transitive dependency, via ros2-arch-deps, so it is not even needed to be added here.

MarsSeed commented on 2023-08-07 18:03 (UTC) (edited on 2023-08-07 18:20 (UTC) by MarsSeed)

Instead of those, you can directly add python-pyqt5 as a dependency, which will pull in its own python-pyqt5-sip requirement.

MarsSeed commented on 2023-08-07 18:01 (UTC)

The issue that originally made sip4 and sip-compat needed was resolved in 2021 by PR#105 (for Melodic and Noetic), and PR#106 (for ROS2).

MarsSeed commented on 2023-08-07 17:43 (UTC)

Also the ros2-pyqt5-sip-compat workaround package seems not to be needed anymore.

MarsSeed commented on 2023-08-05 22:31 (UTC) (edited on 2023-08-05 22:32 (UTC) by MarsSeed)

Please remove the obsolete sip4 dependency.

m2-farzan commented on 2021-04-07 13:58 (UTC)

For feedback or contribution, either comment here or head to this GitHub page: https://github.com/m2-farzan/ros2-rolling-PKGBUILD